SyteLine: Using Bills of Material & Engineering Change Notices (BOM/ECN) Training Workbook
# Table of contents

About this workbook ........................................................................................................ iii
Course overview ............................................................................................................... iv
Course description and agenda ....................................................................................... v
SyteLine user interface ..................................................................................................... vii

**Lesson 1: Introduction to bills of material (BOM)** ....................................................... 1
What is the SyteLine BOM? .............................................................................................. 2
Types of BOMs .................................................................................................................. 3
SyteLine resource model ................................................................................................. 5
Creating a BOM overview ............................................................................................... 7
Origin of BOM default values .......................................................................................... 10
Check your understanding ............................................................................................. 11

**Lesson 2: Creating items for use in a BOM** ............................................................... 13
Introduction ..................................................................................................................... 14
Item fields specific to BOMs ........................................................................................... 15
Check your understanding ............................................................................................. 20

**Lesson 3: Creating resources and work centers for use in a BOM** ......................... 21
Introduction ..................................................................................................................... 22
Creating resource records ............................................................................................. 23
Creating resource groups ............................................................................................... 25
Modeling specific and alternate resources ..................................................................... 26
Creating work center records ........................................................................................ 28
Check your understanding ............................................................................................. 32

**Lesson 4: Creating item routing for use in a BOM** .................................................. 34
Introduction ..................................................................................................................... 35
Creating operation records for an item .......................................................................... 36
Check your understanding ............................................................................................. 43

**Lesson 5: Creating and adding materials** ................................................................. 44
Introduction ..................................................................................................................... 45
Adding materials to an operation .................................................................................. 46
Specifying alternate materials ....................................................................................... 49
Check your understanding ............................................................................................. 56

**Lesson 6: Adding outside operations** .................................................................... 58
Introduction ..................................................................................................................... 59
Setting up outside operations ....................................................................................... 60
Processing an outside operation .................................................................................... 63
Check your understanding ............................................................................................. 65

**Lesson 7: Other BOM activities** ............................................................................. 67
Introduction ..................................................................................................................... 68
Generating Item Current Routing Report ..................................................................... 69
Generating Indented Current BOM Report ................................................................... 70
Copying routings/BOMs ................................................................................................. 71
Use the Engineering Workbench for BOM activities ..................................................... 75
Check your understanding ............................................................................................. 78

**Lesson 8: Setting up Engineering Change Notices (ECNs)** ..................................... 79
Introduction ..................................................................................................................... 80
Activating ECN control ................................................................................................. 81
Setting up change reason codes ................................................................................... 83
Setting up ECN priority codes ....................................................................................... 84
Setting up ECN distribution codes .............................................................................. 85
Check your understanding ............................................................................................. 87

**Lesson 9: Using Engineering Change Notices (ECNs)** ............................................ 88
Introduction ..................................................................................................................... 89
About this workbook

Welcome to this Infor Education course! We hope you will find this learning experience enjoyable and instructive. This Training Workbook is designed to support the following forms of learning:

- Classroom instructor-led training
- Virtual instructor-led training

This Training Workbook is not intended for self-study or as a product user guide.

Activity data

You will be asked to complete some practice exercises during this course. Step-by-step instructions are provided in this guide to assist you with completing the exercises. Where necessary, data columns are included for your reference.

Your instructor will provide more information on systems used in class, including server addresses, login IDs and passwords.

Reference materials

SyteLine reference materials are available from the following locations:

- SyteLine Help menu
- Infor Knowledgezone

Symbols used in this workbook

- Hands-on exercise ("Exercise")
- For your reference
- Instructor demonstration ("Demo")
- Your notes
- Scenario
- Question
- Note
- Answer
Course overview

This course covers the creation and management of bills of material (BOMs) in the SyteLine system, including the item records, routing, resources, and materials that make up the BOM. It also includes instruction on the use of Engineering Change Notices (ECNs) to manage item revisions.

Course duration

1 day

Learning objectives

Upon completion of this course, you will be able to:

- Describe the general procedure for creating a bill of materials (BOM).
- Create item records for use in a BOM.
- Create item operation records, to include outside operations.
- Create resource and work center records.
- Create material records, to include alternate materials and add them to item operations.
- Generate BOM reports.
- Copy routings and BOMs.
- Activate Engineering Change Notice (ECN) control and manage item revisions through ECNs.

Audience

- Customer User
- Pre-Sales Consultant
- Business Consultant
- Technical Consultant
- Support

System requirements

- SyteLine Training Environment

Prerequisite knowledge

To optimize your learning experience, Infor recommends that you have the following knowledge prior to attending this course:

- Knowledge of SyteLine foundational concepts
- Knowledge of how data is structured and organized in SyteLine
- Ability to navigate the SyteLine user interface
Course description and agenda

The purpose of this course is to provide instructions on managing operation records, resources, material records, bills of material (BOMs), and Engineering Change Notices (ECNs) in the SyteLine application. This training is for SyteLine version 9.00 and all previous versions.

Pre-requisites:
- SyteLine User Interface Part 1 – Finding and Working with Forms
- SyteLine User Interface Part 2 – Finding and Displaying Records
- SyteLine User Interface Part 3 – Adding, Editing, and Deleting Records
- SyteLine User Interface Part 4 – Additional Record Management

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Lesson title</th>
<th>Learning objectives</th>
<th>Day</th>
</tr>
</thead>
<tbody>
<tr>
<td>Course overview</td>
<td></td>
<td>• Review course expectations.</td>
<td>Day 1</td>
</tr>
</tbody>
</table>
| Lesson 1 | Introduction to bills of material (BOM) | • Define the SyteLine BOM.  
• Identify the five BOM types.  
• Explain the general procedure for creating a BOM. | Day 1 |
| Lesson 2 | Creating items for use in a BOM | • Identify the key item fields for creating a BOM. | Day 1 |
| Lesson 3 | Creating resources and work centers for use in a BOM | • List the steps for creating a resource record.  
• Describe the use of a resource group.  
• List the steps for creating a work center record.  
• Explain how a work center affects planning and scheduling. | Day 1 |
| Lesson 4 | Creating item routing for use in a BOM | • Identify the key fields on the Current Operations form for creating a BOM.  
• Describe the procedure for adding an operation to an item.  
• Explain how resource groups are assigned to an operation. | Day 1 |
| Lesson 5 | Creating and adding materials | • Identify the key fields on the Current Materials form for creating a BOM.  
• List the steps for adding materials to an operation.  
• Explain how alternate materials are specified for an operation. | Day 1 |
| Lesson 6 | Adding outside operations | • List the system records that must be set up for using outside operations in a routing.  
• Explain the process for creating an item for an outside operation.  
• Describe the procedures for processing an outside operation. | Day 1 |
<table>
<thead>
<tr>
<th>Lesson</th>
<th>Lesson title</th>
<th>Learning objectives</th>
<th>Day</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lesson 7</td>
<td>Other BOM activities</td>
<td>• Explain the use of the Item Current Routing and Indented Current BOM reports.</td>
<td>Day 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Describe the procedure to copy a BOM/routing.</td>
<td></td>
</tr>
<tr>
<td>Lesson 8</td>
<td>Setting up Engineering Change Notices (ECNs)</td>
<td>• List the steps for activating ECN control.</td>
<td>Day 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Identify the supporting code lists that must be set up for ECNs.</td>
<td></td>
</tr>
<tr>
<td>Lesson 9</td>
<td>Using Engineering Change Notices (ECNs)</td>
<td>• Identify the steps for creating an ECN.</td>
<td>Day 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• List the steps for creating an ECN item.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Describe the process for approval/disapproval of an ECN.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Explain how item revisions are made.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Identify the criteria for posting ECNs.</td>
<td></td>
</tr>
<tr>
<td>Course summary</td>
<td></td>
<td>• Debrief course.</td>
<td>Day 1</td>
</tr>
</tbody>
</table>

**Appendices**

There are appendices at the end of this Training Workbook that you may find useful. They contain information that is not part of the instructional content of this course but provide additional related reference information.

<table>
<thead>
<tr>
<th>Appendix</th>
<th>Appendix Title</th>
<th>Content Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appendix A</td>
<td>Review exercises</td>
<td>There are a couple of comprehensive exercises so that you may apply the concepts and practice the procedures covered in the course.</td>
</tr>
<tr>
<td>Appendix B</td>
<td>Reports and utilities</td>
<td>Lists the various BOM-related reports with a description of each report's output. The reports that are introduced in this course are also included.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Lists the various BOM-related utilities with a description of each utility's purpose.</td>
</tr>
<tr>
<td>Appendix C</td>
<td>Phantom items</td>
<td>Lists the various inventory-related utilities with a description of each utility's purpose. The utilities that are introduced in this course are also included.</td>
</tr>
</tbody>
</table>
SyteLine user interface

SyteLine standard user interface elements include the top navigation pane menus and the main toolbar.

![Navigation pane menus and main toolbar](image)

**Navigation pane menus**

You can browse all available folders through the navigation pane menus and submenus. Hovering your mouse over each of the navigation pane menus allows you to explore the submenus contained beneath.

![Navigation pane menus and submenus](image)

**Main toolbar**

The main toolbar contains icons that allow you to quickly complete commonly used tasks in SyteLine, such as saving data or closing a form. You can position your mouse pointer over an icon on the toolbar to reveal its description and functionality.

**Keyboard shortcuts**

Some navigation pane submenus display available keyboard shortcuts that can be used to save multiple steps when completing certain tasks.
The following table displays the available shortcut keys and their actions.

<table>
<thead>
<tr>
<th>Shortcut keys</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Navigating Forms</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl + F4</td>
<td>Close current form.</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Open Select Form.</td>
</tr>
<tr>
<td>Ctrl + W</td>
<td>Open workspaces.</td>
</tr>
<tr>
<td>Ctrl + Tab</td>
<td>Switch view to next open form.</td>
</tr>
<tr>
<td><strong>Navigating records</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Move to first editable field of form.</td>
</tr>
<tr>
<td>Tab</td>
<td>Move to the next field.</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>Move to the previous field.</td>
</tr>
<tr>
<td>F8</td>
<td>Move to the next record.</td>
</tr>
<tr>
<td>F7</td>
<td>Move to the previous record.</td>
</tr>
<tr>
<td>Ctrl + F8</td>
<td>Switch the next collection on the form to become the current collection in a form that contains multiple collections.</td>
</tr>
<tr>
<td>Ctrl + 1</td>
<td>Hide/Show 1st Splitter Pane. Toggles the first splitter pane between being hidden from view and being shown. If the form contains a vertical splitter bar, the first splitter pane is the left pane. For a form that is split horizontally, the top pane is the first splitter pane. Alternatively, select System &gt; View &gt; Hide/Show 1st Splitter Pane.</td>
</tr>
<tr>
<td>Ctrl + 2</td>
<td>Hide/Show 2nd Splitter Pane. Toggles the second splitter pane between being hidden from view and being shown. On a form with a vertical splitter bar, the second splitter pane is the right pane. For a form that is split horizontally, the bottom pane is the second splitter pane. Alternatively, select System &gt; View &gt; Hide/Show 2nd Splitter Pane.</td>
</tr>
<tr>
<td><strong>Editing records</strong></td>
<td></td>
</tr>
<tr>
<td>F2</td>
<td>Activate the drop-down list with an implied asterisk (i.e., wildcard) after the entered text in the field to then populate the list with data entries that begin with the entered text.</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>Add new record. Alternatively, select System &gt; Actions &gt; New. <strong>Note:</strong> The Actions menu is only available when a form is open.</td>
</tr>
<tr>
<td>Ctrl + A</td>
<td>Add value for current field. Alternatively, select System &gt; Edit &gt; Add.</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copy</td>
</tr>
<tr>
<td>Shortcut keys</td>
<td>Action</td>
</tr>
<tr>
<td>--------------</td>
<td>--------</td>
</tr>
<tr>
<td><strong>Editing records, continued</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>Undo. Alternatively, select System &gt; Edit &gt; Undo.</td>
</tr>
<tr>
<td>Ctrl + D</td>
<td>Delete record. Alternatively, select System &gt; Actions &gt; Delete. <strong>Note:</strong> The Actions menu is only available when a form is open.</td>
</tr>
<tr>
<td>Ctrl + F</td>
<td>Find value for current field. Alternatively, select System &gt; Edit &gt; Find Value for Current Field. <strong>Note:</strong> This is only accessible for certain field types, such as some drop-down lists.</td>
</tr>
<tr>
<td>Ctrl + L</td>
<td>Display details for current field drill down. Alternatively, select System &gt; Edit &gt; Details for Current Field. <strong>Note:</strong> This only works for certain field types, such as some drop-down lists.</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save changes. Alternatively, select System &gt; Actions &gt; Save. <strong>Note:</strong> The Actions menu is only available when a form is open.</td>
</tr>
<tr>
<td><strong>Filtering records</strong></td>
<td></td>
</tr>
<tr>
<td>F3</td>
<td>In Filter In Place mode, cancel the filter in place and return to the collection previously displayed. Alternatively, select System &gt; Actions &gt; Filter &gt; Cancel in Place.</td>
</tr>
<tr>
<td>F4</td>
<td>In Refresh/Run mode, begin filter in place (i.e., clear the collection and go back to Filter In Place mode). Alternatively, select System &gt; Actions &gt; Filter &gt; Begin in Place. In Filter In Place mode, execute in place (i.e., run the filter). Alternatively, select System &gt; Actions &gt; Filter &gt; Execute in Place.</td>
</tr>
<tr>
<td>F5</td>
<td>In Refresh/Run mode, refresh the current collection. Alternatively, select System &gt; Actions &gt; Refresh. In Filter In Place mode, clear the filter in place. Alternatively, select System &gt; Actions &gt; Filter &gt; Clear in Place.</td>
</tr>
<tr>
<td>Ctrl + F5</td>
<td>In Refresh/Run mode, refresh the current record. Alternatively, select System &gt; Actions &gt; Refresh current.</td>
</tr>
<tr>
<td>Ctrl + F2</td>
<td>In Refresh/Run mode, repeat Find Value in Collection. Alternatively, select System &gt; Edit &gt; Repeat Find.</td>
</tr>
<tr>
<td>Ctrl + Q</td>
<td>In Refresh/Run or New mode, open associated query form to specify filter criteria. Alternatively, select System &gt; Actions &gt; Filter &gt; By Query.</td>
</tr>
</tbody>
</table>
Other

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Open field level help topic.</td>
</tr>
<tr>
<td>Ctrl + E</td>
<td>Toggle design mode on and off. Alternatively, select System &gt; Edit &gt; Design Mode.</td>
</tr>
<tr>
<td>Ctrl + P</td>
<td>Print</td>
</tr>
</tbody>
</table>

Field types

The following tables display the field types available in SyteLine with a brief description:

<table>
<thead>
<tr>
<th>Field type</th>
<th>Description</th>
</tr>
</thead>
</table>
| Required, system-generated, and read-only fields | • Any field that is required will have a red star  
• A system-generated field will have a green star  
• A field with no border around the data is read-only |

Standard GUI fields

- **Control Point**: Check box indicating Yes or No
- **Gender**: Radio button to select one option from multiple choices
- **Order Type**: Drop-down list to select one option from multiple choices

Forms and reports

Basic SyteLine elements include forms and reports. Forms provide an organized view to the data stored in the database. Just about everything you do in SyteLine uses a form element. You use different types of forms depending on whether you need to add new information, modify existing information, or view the details of a specific record.

- Forms are made up of records that contain multiple fields of data. Records consist of a group of related pieces of information. Fields are the basic elements that display the related data pieces and are grouped together to make up a record.

- When a form displays multiple records, it is referred to as a collection. A collection displays multiple records that have some commonality.

Reports are used to organize and present filtered collections of related data.
Lesson 1: Introduction to bills of material (BOM)

Estimated time
30 minutes

Learning objectives
After completing this lesson, you will be able to:

- Define the SyteLine BOM.
- Identify the five BOM types.
- Explain the general procedure for creating a BOM.

Topics
- What is the SyteLine BOM?
- Types of BOMs
- SyteLine resource model
- Creating a BOM overview
- Origin of BOM default values
What is the SyteLine BOM?

The SyteLine BOM is a comprehensive list of raw materials, components and assemblies required to build or manufacture a product. A BOM is usually in a hierarchical format, with the topmost level showing the end product, and the bottom level displaying individual components and materials.

SyteLine supports the creation of bills of material for manufactured parts. A BOM describes the set of materials needed to complete each of the operations. The BOM can be multi-level, which means one of the materials required for operation xyz is a subassembly that has its own routing and BOM.

In order to manufacture anything, you need instructions. The instructions are broken down into routing and a bill of materials. A routing is a group of operations, or steps that must be performed to assemble an item.

Many enterprise resource planning (ERP) systems store routings and bills in separate records and then require you to match up routings and bills as shown in the table below.

<table>
<thead>
<tr>
<th>Routing for SA-50910</th>
<th>Bill of Materials for SA-50910</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step</td>
<td>Description</td>
</tr>
<tr>
<td>10</td>
<td>Weld</td>
</tr>
<tr>
<td>20</td>
<td>Paint</td>
</tr>
<tr>
<td>30</td>
<td>Assemble</td>
</tr>
<tr>
<td>40</td>
<td>Inspect</td>
</tr>
</tbody>
</table>

However, SyteLine stores them together in what is commonly called a bill of manufacture, which shows each step (routing) and the materials associated with that step (bill of materials) together as shown below.

<table>
<thead>
<tr>
<th>Bill of Manufacture for SA-50910</th>
</tr>
</thead>
<tbody>
<tr>
<td>SA-50910, Bicycle Frame</td>
</tr>
<tr>
<td>10, Weld</td>
</tr>
<tr>
<td>TR-20000, Aluminum Frame</td>
</tr>
<tr>
<td>20, Paint</td>
</tr>
<tr>
<td>PT-10000, Blue Paint</td>
</tr>
<tr>
<td>30, Assemble</td>
</tr>
<tr>
<td>SP-908, Sprocket</td>
</tr>
<tr>
<td>40, Inspect</td>
</tr>
</tbody>
</table>

In this Training Workbook and in the online help the term used for SyteLine’s bill of manufacture is "bill of materials" or "BOM."

2 Lesson 1: Introduction to bills of material (BOM)
© 2014 Infor Education
Types of BOMs

In SyteLine there are five BOM types in order to provide maximum flexibility:

- Current
- Standard
- Job
- Production Schedule
- Estimating

The Current BOM acts as a template. Jobs, production schedules, and estimates all have separate BOM maintenance. This means you can manually create your current BOM and then copy it to individual jobs, production schedules, or estimates. The arrows in the graphic below show which BOM types you can copy to and from.

Notice that you can only copy a Standard BOM (used for costing purposes only) from the Current BOM.
**Current**

When creating a routing (that is, set of operations) and BOM (set of materials) for an item, you must define the operations before you can add materials.

Use the Current Operations form to maintain routing requirements and costing information for an item. In addition, you can create and maintain the list of resources required to perform an operation.

**Standard**

A Standard BOM is used for costing purposes only.

**Job**

The job routing and BOM are required before you can release a job and post transactions for the job (such as issuing materials to the job or moving its finished supply to inventory).

Use the Job Operations form to view and maintain the detailed information and cost rates for a specific job order and operation. You maintain this information both manually and using a series of functions, including scheduling and job transactions.

**Production schedule**

Production schedules are used to record repetitive or flow-based manufacturing processes.

**Estimating**

Estimates are used to estimate customer orders and job orders. They provide quotes for customers detailing the costs and delivery times of goods or services.
Before you begin to create BOMs you need to know all of the parts that are included. Below is the SyteLine resource model.
<table>
<thead>
<tr>
<th>Manufacturing Entity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manufacturing Order</td>
<td>Authorizes manufacturing of a quantity of an item for one level of a BOM. The Scheduler constrains on end-items only. It assumes that any consumable materials have already been allocated to the job and does not treat them as requirements.</td>
</tr>
<tr>
<td>Item</td>
<td>Specifies a BOM, which identifies the sequence of job operations that must be completed to manufacture the item.</td>
</tr>
<tr>
<td>Operations</td>
<td>Each operation specifies up to six skill sets/functions required to perform the operation.</td>
</tr>
<tr>
<td>Resource Group</td>
<td>Each skill set/function is called a resource group. A resource group is a list of similar resources.</td>
</tr>
<tr>
<td>Resource</td>
<td>An entity, such as crewperson, machine, or fixture that can perform the operation.</td>
</tr>
<tr>
<td>Shifts</td>
<td>To identify the times a resource is available for work, you assign up to four shifts to each resource.</td>
</tr>
<tr>
<td>Shift Exceptions</td>
<td>To represent downtime or overtime, you can define shift exceptions for a specific resource on a specific shift. Or you can use holidays to define exceptions in which all resources on all shifts are unavailable.</td>
</tr>
<tr>
<td>Work Center</td>
<td>Captures all costing information from the scheduling activities and does not directly affect the schedule itself.</td>
</tr>
<tr>
<td>Scheduling</td>
<td>The system selects one or more resources from the group, depending on each resource's availability and on rules you define, to perform the operation.</td>
</tr>
</tbody>
</table>
Creating a BOM overview

Procedure
To create a BOM, follow these steps:

1. Create item records.
2. Create shift records.
3. Create resource records. Specify the shift that each resource is working.
4. Create resource groups. Specify the resources that are part of the resource group (the resources with the same skill set or function).
5. Create work center records. You may specify default resource groups that are used with these work centers.
6. Create operation records for your end item. At this time you’ll specify the resource groups, work centers, and manufacturing times used on the operation.
7. Create material records for your operations.

The diagram below depicts the procedural steps for creating a BOM.
Forms
There are three forms you will use when creating a Current BOM:

1. Current Operations - contains information about the time and resources required for an operation.
2. Current Materials - contains information about the materials used for an operation.
3. Engineering Workbench - shows key operation and material fields and allows you to add both operation and material records to a BOM.
   However, because it doesn't contain all of the required fields, you will still need to use the operations and materials forms for some setups.

Each BOM type has its own operations and materials forms. However, the Engineering Workbench is used for all types of BOMs.

In this class you may choose to build BOMs using just the operations and materials forms or using all three.

Current Operations
Notice that this operation is specific to an item. Before you can begin to build a routing, you must first have an item record.

Current Materials
Notice that this record is specific to an item and an operation. Before you begin to build material records, you must first have an item and an operation for that item.
The two sides of this form are independent of each other. As an example, you may look up item FA-10000 in the right pane and it will not refocus the left pane as shown above.

The left pane allows you to see multiple levels of a BOM in indented BOM format if you click the expand symbol ▶ to the left of each entry for each level of the BOM.

The right pane allows you to add operation and material records. If you scroll right on the operation and material fields, you'll see you're able to update most key operation and material fields here.
# Origin of BOM default values

A number of fields on a BOM have default values that are set on other forms. The table below contains a list of the fields on the various forms used for BOMs that have default values originating from other forms. The table does not list the fields that do not have default values originating from other forms.

<table>
<thead>
<tr>
<th>This form...</th>
<th>This field...</th>
<th>Defaults from this form...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work Centers</td>
<td>Overhead Basis</td>
<td>Shop Floor Control Parameters</td>
</tr>
<tr>
<td></td>
<td>Schedule Driver</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Hours per piece or pieces per hour setting</td>
<td>Shop Floor Control Parameters</td>
</tr>
<tr>
<td></td>
<td>Queue Hours</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Move Hours</td>
<td>Shop Floor Control Parameters</td>
</tr>
<tr>
<td></td>
<td>Finish Hours</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Control Point</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Resources</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Efficiency</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Setup Rate</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Run Rate</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Variable Machine</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Fixed Machine</td>
<td>Work Centers</td>
</tr>
<tr>
<td></td>
<td>Variable Labor</td>
<td>Departments</td>
</tr>
<tr>
<td></td>
<td>Fixed Labor</td>
<td>Departments</td>
</tr>
<tr>
<td>Materials</td>
<td>Type</td>
<td>Items</td>
</tr>
<tr>
<td></td>
<td>U/M</td>
<td>Items</td>
</tr>
<tr>
<td></td>
<td>Cost</td>
<td>Item Costs</td>
</tr>
<tr>
<td></td>
<td>Fixed Matl Ovhd</td>
<td>Product Codes</td>
</tr>
<tr>
<td></td>
<td>Variable Matl Ovhd</td>
<td>Product Codes</td>
</tr>
</tbody>
</table>
Check your understanding

In SyteLine, what is the difference between an item routing and a bill of materials?

There are five different BOM types in SyteLine. Which one of the BOM types serves as a master template for the other BOM types?
Place the activities in the correct order that they must be performed to build a bill of materials.

Place a number to the left of each step to indicate the sequence in which each step should be performed.

1. Create item records.
   ___ Create work center records.
   ___ Create resource group records.
   ___ Create operation records for your end item.
   ___ Create shift records.
   ___ Create resource records.

7. Create material records for your operations.
Lesson 2: Creating items for use in a BOM

Estimated time
40 minutes

Learning objectives
After completing this lesson, you will be able to:
- Identify the key item fields for creating a BOM.

Topics
- Introduction
- Item fields specific to BOMs
  - Items form - General tab
  - Items form - Planning tab
  - Inventory parameters
Introduction

Before taking this course, you should have already learned how to create items and the function of many fields on the Items form. In this lesson, we will focus on a few of the item fields that are key to creating BOMs.
Item fields specific to BOMs

**Items form - General tab**

The following fields are those on the Items form, General tab that are useful in a BOM.

**Stocked**

When selected the “Stocked” check box identifies this item as a normally stocked item. It also determines the reference on the Current Materials form when this item is added as a material on a current bill of manufacturing.

The Stocked field and the Source field on the Items form work in conjunction to create default references throughout the system. The following table illustrates how these references are created:

<table>
<thead>
<tr>
<th>If Stocked check box selected =</th>
<th>And Item Source =</th>
<th>Then Reference field on Current Materials form =</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Purchased</td>
<td>Inventory</td>
</tr>
<tr>
<td></td>
<td>Manufactured</td>
<td>Inventory</td>
</tr>
<tr>
<td></td>
<td>Transferred</td>
<td>Inventory</td>
</tr>
<tr>
<td>No</td>
<td>Purchased</td>
<td>Purchase Order or Purchase Order Requisition</td>
</tr>
<tr>
<td></td>
<td>Manufactured</td>
<td>Job</td>
</tr>
<tr>
<td></td>
<td>Transferred</td>
<td>Transfer</td>
</tr>
</tbody>
</table>

**Alternate Item**

References a substitutable or a replacement part. It is used for reference only.

**Type**

- **Material**: Items that are manufactured or consumed in the manufacturing process.
- **Fixture**: Devices that support materials or tools during the machining process.
- **Tool**: Instruments used by a machine to perform an operation.
- **Other**: Non-tangible cost elements on a BOM such as engineering fees or outside process costs.
Source

The sources of the item:
- Purchased
- Manufactured
- Transferred

U/M

Specifies the item’s unit of measure.

Low Level Code

The low-level code represents the lowest level of the item in any current, job, or production schedule bill of materials (BOM). A low-level code of 0 indicates that the item is an end item (finished good) and is not a subcomponent of another item. A low-level code greater than zero indicates that the item is a component of another item. The system supports up to 20 levels of low-level coding.

Items form - Planning tab

The following fields are those on the Items form, Planning tab that are useful in a BOM.

Shrink Factor

Enter the percentage factor by which you wish to increase the quantity of the planned job or order to compensate for expected loss prior to receiving an item to the stockroom. The system decreases the outstanding receipt of the planned job or order by the same amount.

You can enter a maximum factor of 0.9999.

Example: If you want the shrink factor to be 10%, type 0.1.

You can determine the appropriate shrink factor by evaluating historical records that show the amount of scrap reported at the job item level. Use the Job Transactions Report to show historical scrap reported against specific jobs.

The Shrink Factor field is linked to the Yield field on the item’s current operations. When the yield is changed for one or more operations for a given item, that item’s shrink factor is recalculated. When the shrink factor is changed, the yield on the last operation on the item’s routing is recalculated.

How shrink factor is calculated

Shrink Factor = 1 - Yield. The yield is the product of each operation's Yield / 100.

For example, for an item with two operations in its routing:
- Operation 10: Yield = 80%
- Operation 20: Yield = 50%

Shrink Factor = 1 - (80/100 * 50/100) = 1 - 0.4000 = 0.6000
**Phantom Flag**

Select this check box if the system should consider the item a phantom item. A phantom item is usually a subassembly that is not stocked, although you may sell it as a replacement part once in a while, and hence should not be part of the plan.

**Inventory parameters**

The following parameter on the Inventory Parameters form has an effect on some BOM activities.

**Low-Level On Line**

This option lets the system automatically recalculate low-level codes of affected items when a change is made to a BOM or when creating a new BOM.

When making numerous changes to BOMs, it may be faster to clear this option as changes are processed immediately and updating of the low-level codes may slow down the system.

When this check box is not selected and the Current, Job, or Estimating BOM changes, the associated BOM Processor should be run. Once the processor has been run, select this option so that as changes are intermittently made to a bill of manufacturing, the low-level codes will be recalculated automatically.
Demo: Create items for a bill of materials

Your instructor will demonstrate how to create one of the items that will be used later for a bill of materials.

Exercise 2.1: Create items for a bill of materials

In this exercise, you will create items that will be used later in a bill of materials.

Given the popularity of off-the-road mountain bikes, Progressive Cycles has decided to produce two new products.

- GTZ-970 - 22" Chromium Steel Mountain Bike
- MTN-21 - Mountain Bike, 21-SPD

Look ahead to the operation and material practice exercises to get an idea of what you will be building. Before you begin to build operations and materials, you need to create the items below. For any field not specified below, accept the default value. We’re going to give the items a Planner Code to make it easy to search for them if we need to.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Stocked</th>
<th>Type</th>
<th>Source</th>
<th>U/M</th>
<th>Product Code</th>
<th>Planner Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>GTZ-970</td>
<td>22&quot; chromium steel mountain bike</td>
<td>No</td>
<td>Material</td>
<td>Manufactured</td>
<td>EA</td>
<td>FG-100</td>
<td>BOM</td>
</tr>
<tr>
<td>SA-97000</td>
<td>Frame, assembly, reinforced carbon steel</td>
<td>Yes</td>
<td>Material</td>
<td>Manufactured</td>
<td>EA</td>
<td>SA</td>
<td>BOM</td>
</tr>
<tr>
<td>SA-61000</td>
<td>Wheel, 26&quot; mountain</td>
<td>Yes</td>
<td>Material</td>
<td>Purchased</td>
<td>EA</td>
<td>PP</td>
<td>BOM</td>
</tr>
<tr>
<td>PHANT-22</td>
<td>Phantom Hardware, assembly</td>
<td>No</td>
<td>Material</td>
<td>Manufactured</td>
<td>EA</td>
<td>SA</td>
<td>BOM</td>
</tr>
<tr>
<td>MTN-21</td>
<td>Mountain Bike, 21-Speed</td>
<td>Yes</td>
<td>Material</td>
<td>Manufactured</td>
<td>EA</td>
<td>FG-100</td>
<td>BOM</td>
</tr>
<tr>
<td>LX-01</td>
<td>Brake, front and rear</td>
<td>Yes</td>
<td>Material</td>
<td>Purchased</td>
<td>EA</td>
<td>PP</td>
<td>BOM</td>
</tr>
<tr>
<td>21-SPD</td>
<td>Gears, 21-Speed</td>
<td>Yes</td>
<td>Material</td>
<td>Purchased</td>
<td>EA</td>
<td>PP</td>
<td>BOM</td>
</tr>
<tr>
<td>PB-11000</td>
<td>Seat, Gel</td>
<td>Yes</td>
<td>Material</td>
<td>Purchased</td>
<td>EA</td>
<td>PP</td>
<td>BOM</td>
</tr>
<tr>
<td>HB-21000</td>
<td>Handle Bar, tubular reinforced</td>
<td>Yes</td>
<td>Material</td>
<td>Purchased</td>
<td>EA</td>
<td>PP</td>
<td>BOM</td>
</tr>
<tr>
<td>OUT-CG</td>
<td>Outside Custom Graphics</td>
<td>No</td>
<td>Other</td>
<td>Purchased</td>
<td>EA</td>
<td>PP</td>
<td>BOM</td>
</tr>
</tbody>
</table>

- The Phantom Flag check box (Planning tab) should be selected for the PHANT-22.
Exercise steps

1. Open the Master Explorer > Modules > Materials > Inventory > Items form.
2. Turn off the Filter-in-Place mode.
4. Type GTZ-970 in the Item field.
5. Type 22” chromium steel mountain bike in the field below the item field (description).
6. Clear the Stocked check box.
7. Select EA from the U/M drop-down list.
8. Select Material from the Type drop-down list.
9. Select Manufactured from the Source drop-down list.
10. Select FG-100 from the Product Code drop-down list.
11. Save the record.
12. Select the Planning tab.
13. Type BOM in the Planner Code tab
14. Save the record.
15. Repeat steps 3 – 14 to create the other nine items using the field values in the table above for each item.

Note: Be sure to select the Phantom Flag check box on the Planning tab for the PHANT-22 item.
Check your understanding

What does a low-level code of zero indicate for an item?
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________
______________________________________________________________________

Which of the following may be a phantom item in a BOM?

a. An item that cannot be seen
b. A prototype of the end item being manufactured
c. A non-inventoried item that is included for cost balancing
d. A subassembly that is not stocked that may be sold as a replacement part
Lesson 3: Creating resources and work centers for use in a BOM

Estimated time
50 minutes

Learning objectives
After completing this lesson, you will be able to:

- List the steps for creating a resource record.
- Describe the use of a resource group.
- List the steps for creating a work center record.
- Explain how a work center affects planning and scheduling.

Topics
- Introduction
- Creating resource records
- Creating resource groups
- Modeling specific and alternate resources
- Creating work center records
Introduction

Now that the items have been added to the system that will be used in the manufacturing bill of materials that we are creating in this course, we need to set up the various resources and work centers that will be used in the manufacture of the two new off-the-road mountain bikes.

In this lesson you will learn how to add resources and resource groups to the system. You will also learn how to make use of work centers to set default values on operation records and the effect of work centers on planning and scheduling.
Creating resource records

A resource is a non-specific person, machine, or other tool used in at least one step (operation) of the manufacturing process. Examples of a resource are listed below:

- Machine
- Crew
- Fixture
- Space
- Tool

In this course, we do not go into detail about all the fields on the Resources form used for scheduling and planning. For this course, you only need to be able to:

- Create a resource record.
- Complete the header fields.
- Specify the shifts that a resource is available.

Procedure

To add a new resource to the system:

1. Open the Master Explorer > Modules > Production > Work Centers > Resources form.
2. Turn off the Filter-in-Place mode.
4. Type the resource ID into the Resource field.
5. Type the resource description in the field below the Resource field (description).
6. Select the Resource Type from the drop-down list.
   - Labor
   - Machine
   - Other
7. Save the record.

To specify the shifts that a resource is available:

8. Open the resource record on the Resources form for which you are specifying shift availability.
9. Select the Shifts tab.
10. Select a shift from the Shift ID # 1 drop-down list to specify availability of the resource.
11. If needed, select additional shifts from the Shift ID # 2, # 3, or # 4 drop-down lists to specify additional availability of the resource.
12. Save the record.

Resources may use more than one defined shift, and the shifts can overlap. The Scheduler considers the resource available during any of its shifts including an overlap period.

You may select up to four shifts per resource. Multiple resources can reference the same scheduling shift.
If you do not assign a shift to a resource, the resource is considered available 24 hours per day, 7 days per week.

When you reference a scheduling shift on a resource you are telling the Scheduler to make it always effective for that resource. This also applies to that resource in all other BOMs where it is used.
Creating resource groups

An operation specifies one or more resource groups. A resource group is a list of similar resources, such as crew, machines, or fixtures that can perform the operation. The system selects one or more resources from the group, depending on each resource’s availability and on rules you define, to perform the operation.

The member resources may be working different shifts, have different current setups, or have different processing times. You can define a resource as a member of more than one resource group. Also, all the members in a resource group need not be from the same resource type.

In this course, we do not go into detail about all the fields on the Resources Group form used for scheduling and planning. For this course, you only need to be able to:

- Create a resource group record.
- Complete the header fields.
- Specify the resources that are part of the group.

Procedure

To add a new resource group to the system:

1. Open the Master Explorer > Modules > Production > Work Centers > Resource Groups form.
2. Turn off the Filter-in-Place mode.
4. Type the resource group ID into the Group field.
5. Type the resource group description in the Description field.
6. Select the type of resource group from the Type drop-down list.
7. Select the Resources tab.
8. Click the grid on the first line under the Resource column.
9. Select a Resource from the drop-down list.
10. To add additional resources:
    a. Click the grid on the next available line under the first column.
    b. Click the grid on the same line under the Resource column.
    c. Select a Resource from the drop-down list.
11. To change the sequence of the resources
    a. Click the grid on the line of the Resource that you want to re-sequence.
    b. Click Up or Down to change the sequence for the selected resource.
12. Save the record.
Modeling specific and alternate resources

**How to model specific resources**

To assign a specific resource to work on an operation, create a resource group that contains only that resource.

For example, you have five lathes. One of them is new and is the only machine that you can use on a subset of the items you manufacture. You can create these resource groups:

<table>
<thead>
<tr>
<th>Resource Group</th>
<th>Resources</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lathes</td>
<td>Old lathe 1</td>
</tr>
<tr>
<td></td>
<td>Old lathe 2</td>
</tr>
<tr>
<td></td>
<td>Old lathe 3</td>
</tr>
<tr>
<td></td>
<td>Old lathe 4</td>
</tr>
<tr>
<td>New Lathe</td>
<td>New lathe 1</td>
</tr>
</tbody>
</table>

Then on the operation form for the items that require the new lathe, you would specify the New Lathe resource group. The Scheduler would only load those items on the new lathe.
How to model alternate resources

SyteLine's resource model allows you to specify alternate resources for a routing by using resource groups and resource group member selection rules.

For example, suppose there is a lathe operation for a jet engine ring that normally requires New Lathe 1. If that lathe is not available, the job can alternatively be run using Old lathe 1 or Old lathe 3. However, you always want to use New lathe 1 if it is available.

Here is how you could set up the resource group that is assigned to the operation:

<table>
<thead>
<tr>
<th>Resource Group</th>
<th>Resources</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jet engine ring lathes</td>
<td>New lathe 1</td>
</tr>
<tr>
<td></td>
<td>Old lathe 1</td>
</tr>
<tr>
<td></td>
<td>Old lathe 3</td>
</tr>
</tbody>
</table>

On the General tab of the Resource Groups form, an allocation rule can be selected from a drop-down list.

Select the Select In Sequence allocation rule to specify that the resource group’s resources are to be selected in the same order as they are listed on the Resources tab.

For operations that are assigned this resource group, if New lathe 1 is available, it is loaded. If not, then the next available resource in the list is loaded to perform the operation.

Because resources can be members of many groups, you could create many such resource groups in which New lathe 1 is a member or the primary resource.
Creating work center records

Effect of work centers on planning and scheduling

Work centers are not directly used in planning and scheduling activities. However, the information in some of the fields on the Work Centers form will become default values for some fields on the Operations form. Most of these fields are related to costing, but a few of them affect planning and scheduling. They are:

- Schedule Driver (defaults from resource group)
- Efficiency (affects cost and scheduling)
- Queue Hours (wait time prior to operation)
- Finish Hours (wait time after operation)
- Resource Groups (scheduling)

All work center defaults may be overwritten at the operation level. You do not have to specify any field on a work center record besides the Department field; other fields are used for convenience when setting up operations.

Procedure

To add a new work center record to the system:

1. Open the Master Explorer > Modules > Production > Work Centers > Work Centers form.
2. Turn off the Filter-in-Place mode.
4. Type the work center ID into the Work Center field.
5. Type the work center description into the field to the right of the Work Center field.
6. Select a Department from the drop-down list on the Scheduling tab.
7. Select the Resources Groups tab.
8. Click the grid on the first line under the Group column.
9. Select a Resource Group from the drop-down list.
10. Type the quantity of the selected Resource Group in the field under the Quantity column.
11. To add additional resource groups:
   a. Click the grid on the next available line under the first column.
   b. Click the grid on the same line under the Group column.
   c. Select a Resource Group from the drop-down list.
   d. Type the quantity of the selected Resource Group in the field under the Quantity column.
12. Save the record.

For descriptions of the Schedule Driver, Efficiency, Queue Hours, and Finish Hours fields, see Lesson 4 of this course, Creating item routing for use in a BOM.
Demo: Resources, resource groups, and work centers

Your instructor will demonstrate how to create a resource, a resource group, and a work center.

Exercise 3.1: Resources, resource groups, and work centers

In this exercise, you will create resources, resource groups, and work centers that will be used later in a bill of materials.

You need to create resources, resource groups, and work centers for operations that require:

- Assembly
- Inspection
- Drilling

Exercise steps

Part 1: Resources

Use the information in the following table to create eight new resources:

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
<th>Type</th>
<th>Shifts</th>
</tr>
</thead>
<tbody>
<tr>
<td>AS-600-L1</td>
<td>Assembly crew</td>
<td>Labor</td>
<td>1shift</td>
</tr>
<tr>
<td>AS-600-L2</td>
<td>Assembly crew</td>
<td>Labor</td>
<td>1shift</td>
</tr>
<tr>
<td>AS-600-L3</td>
<td>Assembly crew</td>
<td>Labor</td>
<td>2shift</td>
</tr>
<tr>
<td>AS-600-L4</td>
<td>Assembly crew</td>
<td>Labor</td>
<td>2shift</td>
</tr>
<tr>
<td>INS-30-L1</td>
<td>Inspection crew</td>
<td>Labor</td>
<td>1shift</td>
</tr>
<tr>
<td>INS-30-L2</td>
<td>Inspection crew</td>
<td>Labor</td>
<td>2shift</td>
</tr>
<tr>
<td>DRL-20-M1</td>
<td>Drilling machine</td>
<td>Machine</td>
<td>1shift &amp; 2shift</td>
</tr>
<tr>
<td>DRL-20-M2</td>
<td>Drilling machine</td>
<td>Machine</td>
<td>1shift &amp; 2shift</td>
</tr>
</tbody>
</table>

1. Open the Master Explorer > Modules > Production > Work Centers > Resources form.
2. Turn off the Filter-in-Place mode.
4. Type AS-600-L1 into the Resource field.
5. Type Assembly crew into the field below the Resource field (description).
6. Select Labor from the Resource Type drop-down list.
7. Save the record.
8. Select the Shifts tab.
13. Select 1shift from the Shift ID # 1 drop-down list to specify availability of the resource.
14. Save the record.
15. Repeat steps 3 – 10 to create the other seven resources using the field values in the table above for each resource.

TIP: For faster data entry, right-click an existing resource record and select the Copy option. Then edit the necessary fields for the new resource and save the record.

Part 2: Resource groups

Use the information in the following table to create three new resource groups:

<table>
<thead>
<tr>
<th>Group</th>
<th>Description</th>
<th>Type</th>
<th>Resources</th>
</tr>
</thead>
<tbody>
<tr>
<td>AS-600-LRG</td>
<td>Assembly</td>
<td>Labor</td>
<td>All of the AS-600 resources.</td>
</tr>
<tr>
<td>DRL-20-MRG</td>
<td>Drilling</td>
<td>Machine</td>
<td>All of the DRL-20 and DRL-10 resources. Be sure the DRL-10 resources are last in the sequence.</td>
</tr>
<tr>
<td>INS-30-LRG</td>
<td>Inspection</td>
<td>Labor</td>
<td>All of the INS-30 resources and the AS-500 resources. Be sure the AS-500 resources are last in the sequence.</td>
</tr>
</tbody>
</table>

1. Open the Master Explorer > Modules > Production > Work Centers > Resource Groups form.
2. Turn off the Filter-in-Place mode.
4. Type AS-600-LRG into the Group field.
5. Type Assembly into the Description field.
6. Select Labor from the Type drop-down list.
7. Select the Resources tab.
8. Click the grid on the first line under the Resource column.
10. Click the grid on the next available line under the first column.
11. Click the grid on the same line under the Resource column.
13. Click the grid on the next available line under the first column.
14. Click the grid on the same line under the Resource column.
15. Select AS-600-L3 from the Resource drop-down list.
16. Click the grid on the next available line under the first column.
17. Click the grid on the same line under the Resource column.
19. Save the record.
20. Repeat steps 3 – 19 to create the other two resource groups using the field values in the table above for each resource group.

Part 3: Work centers

Use the information in the following table to create three new work centers:

<table>
<thead>
<tr>
<th>Work Center</th>
<th>Description</th>
<th>Department</th>
<th>Resource Groups</th>
</tr>
</thead>
<tbody>
<tr>
<td>AS-600</td>
<td>Assembly</td>
<td>100</td>
<td>Qty of 1 AS-600-LRG</td>
</tr>
<tr>
<td>DRL-20</td>
<td>Drilling</td>
<td>200</td>
<td>Qty of 1 DRL-20-MRG</td>
</tr>
<tr>
<td>INS-30</td>
<td>Inspection</td>
<td>300</td>
<td>Qty of 1 INS-30-LRG</td>
</tr>
</tbody>
</table>

Because work centers require GL accounting codes, the easiest way to create these is to open an existing work center record, right-click the record and select the Copy option. Then edit the necessary fields for the new work center and save the record.

1. Open the Master Explorer > Modules > Production > Work Centers > Work Centers form.
2. Turn off the Filter-in-Place mode.
3. Select the AS-500 work center from the list on the left side of the screen.
4. Right-click the record and select the Copy option.
5. Select AS-500 in the Work Center field and type AS-600 to replace the existing text.
6. Select Assembly area in the field to the right of the Work Center field and type Assembly to replace the existing text.
7. Select 100 from the Department drop-down list on the Scheduling tab.
8. Select the Resource Groups tab.
9. Click the grid on the first line under the Group column.
10. Select AS-600-LRG from the Resource Groups drop-down list.
11. Save the record.
12. Repeat steps 3 – 11 to create the other two work centers using the field values in the table above for each work center.
Check your understanding

How can you assign one specific resource to an operation?

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

_____________________________________
_____________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

After creating a new resource, what happens if you do not assign a shift to it?

a) The resource can’t be scheduled.
b) The shift for the resource defaults to first shift, 5 days per week.
c) The resource is considered available 24 hours a day, 7 days per week
d) The resource record can’t be saved until you assign it a shift.
True or false. Resources cannot be directly assigned to operations. They must be part of a resource group.

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

How do you specify that the member resources of a resource group are to be selected for an operation in the same order as they are listed in the resource group?

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
Lesson 4: Creating item routing for use in a BOM

Estimated time
40 minutes

Learning objectives
After completing this lesson, you will be able to:

- Identify the key fields on the Current Operations form for creating a BOM.
- Describe the procedure for adding an operation to an item.
- Explain how resource groups are assigned to an operation.

Topics
- Introduction
- Creating operation records for an item
Introduction

The items that will be used in the manufacturing bill of materials that we are creating in this course have been added. We have also defined the resources that will be used in the manufacturing process for our two new products. Resource groups and work centers have also been created. Now it is time to define the routings, or set of operations to be used for the production of the items.

In this lesson you will learn how to add operations records to an item routing, set production times, and assign resource groups to each operation.
Creating operation records for an item

An operation specifies the times, resources required, and costs of a manufacturing process step.

In this course, we do not go into detail about all the scheduling, planning, and costing fields on the Operations form. For this course, you only need to be able to:

- Create an operations record.
- Fill in the manufacturing time fields.
- Specify resource groups required to perform this operation.

When creating or modifying operation information, you can use two forms:

- Engineering Workbench (for all BOM types)
- Operations form for the BOM type you want to work with

Procedure

Use the Standards tab to maintain or view routing requirements for an item. Use the Resources tab to maintain the list of resource groups that can work on this operation. An operation must specify at least one resource group. Use the Costs tab to maintain cost rates of the operations.

To add operation records to a new item routing:

1. Open the Master Explorer > Modules > Materials > Product Definition > Current Operations form.
2. Turn off the Filter-in-Place mode.
4. Select the item for which you are creating the routing from the Item drop-down list.
5. Select an operation number from the drop-down list or accept the default number.
6. Select a work center from the drop-down list.
7. Save the record.
8. Complete the fields on the Standards tab for the operation. Use the field descriptions in the table under the Current Operations – Standards tab below as a guide.
9. Save the record.
10. Select the Resources tab.
11. Verify that at least one resource group for the operation has been assigned to the item. It should show the resource group associated with the work center selected in Step 6. You can change the default resource group or add additional groups. Use the field descriptions in the table under the Current Operations – Resources tab below as a guide.
12. Save the record.
13. To add a note to the operation:
   a. Select Actions > Notes for Current.
   b. Type a subject for the note into the Subject field.
   c. Select the Internal check box.
   d. Type the text of the note into the Note field.
   e. Click OK.
14. Click Create a new object in the current collection in the main toolbar.
15. Repeat steps 5 through 14 until you have added all of the operations to the item routing.

## Current Operations – Standards tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fixed Schedule Fields</strong></td>
<td></td>
</tr>
<tr>
<td>Use Fixed Schedule</td>
<td>Select the Use Fixed Schedule field to set a fixed time for this operation regardless of lot size. Selecting this field will also update the Scheduler Rule on the resources tab.</td>
</tr>
</tbody>
</table>
| Fixed Sched Hours          | If the Use Fixed Schedule check box is selected, enter the expected total amount of time for the operation in this field. When you use fixed hours, the Scheduler will ignore the values you have in the hours/piece and setup fields. The processing time for the operation will include:  
  - Fixed Sched Hours  
  - Move hours  
  - Queue hours  
  - Finish hours                                                                                                                                                                                                                                                                                                                                                           |
| **Hours/Piece Fields**     |                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     |
| Machine Hours per Piece    | Estimate of the hours of run time to produce one piece. If Sched Driver field = Machine, then enter a value in this field or in the Pieces per Machine Hour field.                                                                                                                                                                                                                                                                                        |
| Pieces per Machine Hour    | Represents the pieces that can be produced in a single machine hour. If Sched Driver field = Machine, then enter a value in this field or in the Machine Hours per Piece field.                                                                                                                                                                                                                                                                                          |
| Labor Hours per Piece      | Estimate of the hours of cycle time to produce one piece. If Sched Driver field = Labor, then enter a value in this field or in the Pieces per Labor Hour field.                                                                                                                                                                                                                                                                                     |
| Pieces per Labor Hour      | Represents the pieces that can be produced in a single labor hour. If Sched Driver field = Labor, then enter a value in this field or in the Labor Hours per Piece field.                                                                                                                                                                                                                                                                                     |
| Sched Driver               | Labor or Machine                                                                                                                                                                                                                                                                                                                                                                                                                           |
| Run Duration               | Displays the processing time (adjusted for efficiency) for the operation that advanced planning and scheduling (APS) and the Scheduler will use to plan or schedule the resources for this operation. The system divides the Machine Hours Per Piece or Labor Hours Per Piece value by the number of resources from the Schedule Driver resource group type, and multiplies the value by \(\frac{100}{\text{Efficiency}}\).                                                                                                                                                                           |
| Yield                      | The percentage amount you expect to finish at this operation. An item’s shrink factor is linked to the yield amount. When the yield is changed for one or more operations for a given item, that item’s shrink factor is recalculated. When the shrink factor is changed, the yield on the last operation on the item’s routing is updated. See Shrink Factor in Lesson 2.  
  - The yield on the last operation on the item’s routing is updated. See Shrink Factor in Lesson 2.                                                                                                                                                                                                                                                                   |
| **Hours Fields**           |                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     |
| Move                       | Time of movement of work in progress (WIP) from the previous operation to this operation.                                                                                                                                                                                                                                                                                                                                                                                                         |
| Queue Time                 | Estimated amount of time you expect the item to wait before being processed at this operation.                                                                                                                                                                                                                                                                                                                                          |
Field | Description
--- | ---
| | operation.
| Setup | Time to set up this operation.
| Finish | Delay between completion of this operation and the start of the next operation in the routing.
| Use Offset | Select this check box to allow this operation to start before the previous operation completes. This allows overlapping operations, which is often used with assembly lines and cells. **Note:** This is not a setting for parallel processing.
| Offset Hours | Enter hours that will be used in the offset load splitting calculation. Various activities use offset hours as follows:

- **APS.** Offset is time-based. APS starts the operation the specified number of hours AFTER SETUP BEGINS on the previous operation. For example, 1 hour of offset means the planner begins the operation with an offset of 1 hour after setup starts on the previous operation.
- **Scheduler.** Offset is load-based. The Scheduler splits the load at the operation into smaller loads WHEN SETUP FINISHES. When these smaller loads finish at the operation they move independently to the next operation. The size of these smaller loads depends on the offset hour size and the hours per piece or fixed time.
- **Lead Time Processor.** Offset is time to wait. Reduces total lead time by the offset hours.

Yield on job order operations affects the job’s expected quantity.

**Expected quantity = Released quantity * Yield.**

Material requirements planning (MRP) and APS assume the expected quantity, not the released quantity, will be available for supply.

All times should be entered as hours in decimal format. For example, an expected setup time of 45 minutes (45/60) is entered as 0.75.
Current Operations – Resources tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Group and Description</td>
<td>You MUST specify at least one resource group for an operation. Enter up to six resource groups needed for this operation.</td>
</tr>
<tr>
<td>Quantity</td>
<td>Enter the number of resources from this group required for the operation.</td>
</tr>
<tr>
<td>Setup Resource Group</td>
<td>Select the resource group from the drop-down list that is designated for the setup of this operation. The resource group you select must be allocated to this operation or must be allocated to a previous operation using the &quot;Hold&quot; action code; otherwise, an error occurs during scheduling. The resource that is allocated from this group will be the resource the Scheduler uses to determine the setup time based on the criteria you defined (by item, by setup group, etc). All resources required on the operation are allocated for the setup time. If you entered a setup time on the Standards tab, then you must select a setup resource group. <strong>Note</strong>: If you do not specify a setup resource group, this operation will not incur setup time.</td>
</tr>
</tbody>
</table>

Current Operations – Costs tab

The Costs tab contains both the direct (costing) and indirect (overhead rates) costs of the operation.

For more details on costing, see the SyteLine Help files or the SyteLine: Costing Training Workbook.
Demo: Item routing
Your instructor will demonstrate how to create an operation record for a new item routing.

Exercise 4.1: Item routing
In this exercise, you will add operation records to create four different item routings.

Exercise steps
Part 1: Item routing for item GTZ-970
Use the information in the following table to create a routing consisting of four operations for item GTZ-970:

<table>
<thead>
<tr>
<th>Oper</th>
<th>WC</th>
<th>Description</th>
<th>Move Hrs</th>
<th>Queue Hrs</th>
<th>Setup Hrs</th>
<th>Hrs / Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>FA-400</td>
<td>Final Assembly</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.3</td>
</tr>
<tr>
<td>20</td>
<td>INS-30</td>
<td>Inspection</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.083</td>
</tr>
<tr>
<td>30</td>
<td>PKG-10</td>
<td>Packaging</td>
<td>0.2</td>
<td>0.0</td>
<td>0.1 **</td>
<td>0.2</td>
</tr>
<tr>
<td>40</td>
<td>ST-100</td>
<td>Staging</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.01</td>
</tr>
</tbody>
</table>

* When entering the hours per piece values, make sure you enter it into the hours per piece field that matches the schedule driver for the operation.

** Be sure to update the Setup Resource Group field on the Resources tab for operation 30.

Add an Outside Process operation to the GTZ-970 routing:

<table>
<thead>
<tr>
<th>Oper</th>
<th>WC</th>
<th>Description</th>
<th>Move Hrs</th>
<th>Queue Hrs</th>
<th>Setup Hrs</th>
<th>Hrs / Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>PS-300</td>
<td>Outside Processes</td>
<td>0.0</td>
<td>0.0</td>
<td>0.0</td>
<td>0.0</td>
</tr>
</tbody>
</table>

Add the note to the right to this operation. The purpose of this operation is to include frame graphics on our GTZ-970 mountain bike. We will be sending the frame to JA Graphics to have customized flames painted on the side of the GTZ-970. We know our customers will love this new design!
1. Open the Master Explorer > Modules > Materials > Product Definition > Current Operations form.
2. Turn off the Filter-in-Place mode.
4. Select GTZ-970 from the Item drop-down list.
5. Select 10 from the Operation drop-down list.
6. Select FA-400 from the Work Center drop-down list.
7. Save the record.
8. Type 0.2 into the Move field.
9. Type 0.0 into the Queue Time field.
10. Type 0.0 into the Setup field.
11. Type 0.3 into the Labor Hours per Piece field.
12. Save the record.
13. Repeat steps 3 – 12 to create the other three operations for the GTZ-970 item routing using the field values in the table above for each operation.
14. For operations to which you need to add a note, follow these steps:
   a. Select Actions > Notes for Current.
   b. Type a [subject] for the note into the Subject field.
   c. Select the Internal check box.
   d. Type the [text of the note] (or copy and paste) into the Note field.
   e. Click OK.
15. Apply this set of steps to create the other three item routings in the other parts of this exercise using the values in the appropriate tables for the routing.

Part 2: Item routing for item SA-97000
Use the information in the following table to create a routing consisting of four operations for item SA-97000:

<table>
<thead>
<tr>
<th>Oper</th>
<th>WC</th>
<th>Description</th>
<th>Move Hrs</th>
<th>Queue Hrs</th>
<th>Setup Hrs</th>
<th>Hrs / Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AS-600</td>
<td>Assembly</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.1</td>
</tr>
<tr>
<td>20</td>
<td>DRL-20</td>
<td>Drilling</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.2</td>
</tr>
<tr>
<td>30</td>
<td>INS-30</td>
<td>Inspection</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.5</td>
</tr>
<tr>
<td>40</td>
<td>ST-100</td>
<td>Staging</td>
<td>0.2</td>
<td>0.0</td>
<td>0.0</td>
<td>0.01</td>
</tr>
</tbody>
</table>

Add the note to the right to Operation 10. The purpose of this operation is to assemble the handlebars, seat, and frame. Make sure the chain is properly lubricated.

Add the note to the right to Operation 20. After drilling has been completed, make sure that the rough edges are filed.
Part 3: Item routing for item MTN-21

Use the information in the following table to create a routing consisting of one operation for item MTN-21:

<table>
<thead>
<tr>
<th>Oper</th>
<th>WC</th>
<th>Description</th>
<th>Move Hrs</th>
<th>Queue Hrs</th>
<th>Setup * Hrs</th>
<th>Hrs / Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AS-600</td>
<td>Assembly</td>
<td>0.2</td>
<td>0.0</td>
<td>2.0</td>
<td>0.5</td>
</tr>
</tbody>
</table>

* Be sure to update the **Setup Resource Group** field on the **Resources** tab for **operation 10**.

Part 4: Item routing for item PHANT-22

Use the information in the following table to create a routing consisting of one operation for item PHANT-22:

<table>
<thead>
<tr>
<th>Oper</th>
<th>WC</th>
<th>Description</th>
<th>Move Hrs</th>
<th>Queue Hrs</th>
<th>Setup Hrs</th>
<th>Hrs / Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Phantm</td>
<td>Phantom WC</td>
<td>0.0</td>
<td>0.0</td>
<td>0.0</td>
<td>0.0</td>
</tr>
</tbody>
</table>

Add the note to the right to Operation 10.

This phantom item represents the mountain bike that we will be making. It will facilitate the future creation of all routings and bills of material of our mountain bikes, which differ only by the number of speeds on them.
Check your understanding

When entering the hours per piece on an operation record, the value of which field determines whether the Machine Hours per Piece field or the Labor Hours per Piece field is used?

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

An item’s yield amount for an operation is linked to which field on the item record?

a) Shrink Factor
b) Lot Number
c) Safety Stock Percent
d) Unit Cost

For an operation, the delay time between the completion of this operation and the start of the next operation in the routing describes which field on the Operations form?

a) Move
b) Queue Time
c) Setup
d) Finish
Lesson 5: Creating and adding materials

Estimated time

50 minutes

Learning objectives

After completing this lesson, you will be able to:

- Identify the key fields on the Current Materials form for creating a BOM.
- List the steps for adding materials to an operation.
- Explain how alternate materials are specified for an operation.

Topics

- Introduction
- Adding materials to an operation
- Specifying alternate materials
Introduction

We almost have everything we need to create the bills of material for the two new products. In the previous lesson we created the routings with groupings of operations that define the steps to assemble the products. In those routings, we defined our production standards and assigned resource groups for each operation. Now we need to add the materials that are needed to the appropriate operations.

In this lesson you will learn how to add materials to operations, and how to specify alternate materials as needed.
Adding materials to an operation

A material specifies the items required to perform a given operation.

In this course, we do not go into the details about all of the costing fields for a materials record. For this course, you only need to be able to:

- Create a material record.
- Fill in the quantity per fields.

When creating or modifying material information, you can use two forms:

- Engineering Workbench (for all BOM types)
- Materials form for the BOM type you want to work with

Procedure

To add materials to a routing operation:

1. On the Operations form, click Materials to add materials to an operation, if needed. The appropriate materials form for the BOM type you are working with will open as follows:
   - Inventory item: Current Materials form
   - Job: Job Materials form
   - Production schedule item: Production Schedule Item Materials form
   - Production schedule release: Production Schedule Release Materials form
   - Estimate job: Estimate Materials form

2. Select Actions > New to add a new material.

3. Select an item from the Material drop-down list.

4. Enter the data in the appropriate fields on the Materials tab for the selected material. Use the field descriptions in the table under the Current Materials – Materials tab below as a guide.

5. Enter the data in the appropriate fields on the Costs tab for the selected material.

6. Enter the data in the appropriate fields on the Resources tab for the selected material. Use the field descriptions in the table under the Current Materials – Resources tab below as a guide.

7. Save the record.
### Current Materials – Materials tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Required field. Select the material to be added to the operation from the drop-down list. This can be an inventoried or non-inventoried Item. The system will apply cost per unit for inventoried items. Non-inventoried items might be supply items that will not directly affect costing of the job. These charges could be captured in the overhead accounts.</td>
</tr>
<tr>
<td>Quantity</td>
<td>The number of units of this material required per unit or lot to manufacture the item.</td>
</tr>
<tr>
<td>Per Lot Quantity/Unit</td>
<td>These radio buttons indicate if the quantity needed of the material is per unit or per lot. If per lot is selected, then the planner calculates one item to be used for the whole job regardless of the quantity of the parent item to be produced or the lot size on the parent item record.</td>
</tr>
<tr>
<td>Scrap Factor</td>
<td>The percentage of expected scrap incurred during manufacturing for the component material. This percentage should be expressed as a decimal, e.g. 10% is entered as &quot;0.1,&quot; not &quot;10.&quot; When using a scrap factor the total quantity is calculated as:&lt;br&gt;[ \text{Total Quantity} = \text{Quantity} \times (1 - \text{Scrap Factor}) ]</td>
</tr>
<tr>
<td>Probable</td>
<td>This field is the percentage of probability that this component will be used in the manufacturing of the product. This field is unavailable if the configuration flag is not selected.&lt;br&gt;If the configuration flag for this item is selected, then the quantity will be calculated as:&lt;br&gt;[ \text{Total Quantity} = \text{Quantity} \times \text{Probable} ]&lt;br&gt;Deliberate over-planning and under-planning are allowed.</td>
</tr>
<tr>
<td>Effective</td>
<td>If there's a date in this field, the planner will ignore this operation or material previous to the effective date. The default of a blank date turns this feature off. This field will appear only on the Current Operations and Current Materials screens.</td>
</tr>
<tr>
<td>Obsolete</td>
<td>If there's a date in this field, the planner will ignore this operation or material after the date set. The default of a blank date turns this feature off. This field will appear only on the Current Operations and Current Materials screens.</td>
</tr>
<tr>
<td>Backflush</td>
<td>Select this check box if the material is to be backflushed. This field defaults to what was selected on the Controls tab of the item record.</td>
</tr>
<tr>
<td>Backflush Location</td>
<td>This field can be updated only if the Backflush check box has been selected. If left blank, the system checks the hierarchy during the backflushing process to obtain a backflush location. At any point in the validation process that the system encounters a valid backflush location it will use that location and ignore any other values set at higher levels. The order in which the system validates a backflush location is:&lt;br&gt;1. Current/Job/Production Schedule Materials&lt;br&gt;2. Floor stock locations for item at the operations work center&lt;br&gt;3. Item Maintenance - Controls&lt;br&gt;4. Inventory Parameters.</td>
</tr>
<tr>
<td>Alt Group</td>
<td>This field is used when defining a group of alternate materials for an operation. See the Specifying alternate materials topic later in this lesson.</td>
</tr>
<tr>
<td>Alt Group Rank</td>
<td>This field identifies the priority rank for this alternate material within the alternate group of which it is a member. See the Specifying alternate materials topic later in this lesson.</td>
</tr>
</tbody>
</table>
Current Materials – Costs tab

The Costs tab contains both the direct (unit costs) and indirect (overhead rates) costs of the material.

For more details on costing, see the SyteLine Help files or the SyteLine: Costing Training Workbook.

Current Materials – References tab

The system provides the operational use of three different reference numbers. These are useful when referencing where items (or components) appear on a drawing.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly Seq</td>
<td>Identifies the sequence in which the component is inserted into the assembly.</td>
</tr>
<tr>
<td>Ref Seq</td>
<td>The sequence of the reference. It increments by one with each added reference line.</td>
</tr>
<tr>
<td>Reference Designator</td>
<td>Identifies the location of the component on the assembly drawing, typical of an electronic assembly.</td>
</tr>
<tr>
<td>Bubble #</td>
<td>Sometimes referred to as a &quot;Balloon&quot; number, it indicates the identifier assigned to the component on the assembly drawing, typical in mechanical assemblies.</td>
</tr>
</tbody>
</table>
Specifying alternate materials

How to specify alternate materials for an operation

Suppose you have a BOM that looks like this:

```
Item 1 (end item)
  Item 2 (subassembly)
    Item 3a (component)  Alt Group Rank
    Item 3b (alternate component)  1
    Item 3c (2nd alternate component)  2
```

Sample BOM

In this example, Item 3a is the primary material of an Alternate Group. Items 3b and 3c are alternate materials for Item 3a. Any one of the three materials can be used to make Item 2.

To set up alternate materials for an operation, follow these steps.

1. Before you begin you should plan in advance the alternate materials that an item may have and the order in which the system should select them.
2. When you add these materials to an operation, add the primary material item record first.
3. Take note of the Alt Group number that appears to the right of the Material field. Also notice that the Alt Group Rank is set to 0. This identifies the material as the primary material in an Alternate Group. The system plans alternate materials in order of Alt Group Rank, and will always attempt to plan the primary material first. You cannot change the rank value after you save the record, so make sure this is the item you want as the primary item.
4. Enter the appropriate information in the remaining fields to complete the definition of this material and save the record.
5. Select Actions > New to add the next material record.
6. Select the first alternate material to the previous material in the Material drop-down list. Notice that the Alt Group number will be the next higher number than it was for the previous material.
7. To make this material an alternate for the previous material, change the Alt Group number to the same number that the primary material has. See step 3 above.
8. Notice that the Alt Group Rank for this material is 1.
9. Complete the other information for this alternate material and save the record.
10. Repeat steps 5 through 9 to add additional alternate materials as needed.

You cannot change a material's Alt Group after you save the record (however, you can delete it and then re-add it with a different group ID if necessary).
How to change the ranking within an alternate group

You can change the rank of each alternate material using the Ranks for Alternate Materials form. Follow these steps.

1. On the Current Materials form, select the material record for the primary material from the grid on the left side.
2. Click Ranks. The Ranks for Alternate Material form opens.
3. Select the record for the alternate material for which you want to change the ranking and click Up or Down to re-sequence the material in the list.
4. Save the record.

If you delete an item record in current materials that is a member of an alternate group, the material(s) that are lower in the rank structure for that group move up in rank accordingly. You cannot delete an item record if it is the primary material in an alternate group.

Copying planned alternate materials to the production BOM

When the Planning activity plans a job, production schedule release, or MPS order that has no routing/bill of materials, it plans using the item's current routing/BOM. In this situation, when you firm a planned order or MPS receipt that results from the job, production schedule release, or MPS order, any alternate materials the system used when it planned the current BOM will be copied to the job or production schedule BOM.

About rollup of alternate material costs to standard BOM

When you roll up the cost of the current routing/BOM to the standard routing/BOM (using Current BOM Cost Rollup or Roll Current Cost to Standard Cost), the cost of alternate materials is not rolled up to the standard routing/BOM.
Demo: Current materials
Your instructor will demonstrate how to add a material to an operation.

Exercise 5.1: Current materials
In this exercise, you will finish the bills of material for the new products, the GTZ-970 and the MTN-21, by creating material records for the operations in the item routings and their subassemblies.

Here are graphical representations of the whole material structure for both items.
The BOM for SP-11000 already exists in the database, so you will need to add material records to these items’ routings:

- SA-97000
- GTZ-970
- PHANT-22
- MTN-21

Use the data in the tables in the four parts of the exercise.

**Exercise steps**

Part 1: Materials for item **SA-97000**

Here’s a graphical representation of the material structure for the first level of item SA-97000.
Use the information in the following table to add materials to the current operations of item **SA-97000**:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Material</th>
<th>Qty</th>
<th>Per</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 - ASSEMBLY</td>
<td>TA-20000</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - ASSEMBLY</td>
<td>TA-40000</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - ASSEMBLY</td>
<td>SP-11000</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - ASSEMBLY</td>
<td>PB-11000</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - ASSEMBLY</td>
<td>HB-21000</td>
<td>1</td>
<td>Unit</td>
</tr>
</tbody>
</table>

Add the note to the right to the HB-21000 material record. **Make sure that the handlebars selected for assembly have not been scratched.**

Add the items to the right to be alternate materials for the PB-11000 material record.

1. PB-10000
2. CP-10000
3. TS-10000

1. Open the Master Explorer > Modules > Materials > Product Definition > Current Operations form.
2. Turn off the Filter-in-Place mode.
3. Select **SA-97000, Operation 10** from the grid on the left side of the screen.
4. Click **Materials** to open the Current Materials form.
5. Select **Actions > New**.
6. Select **TA-20000** from the Material drop-down list.
7. Type 1 into the Quantity field.
8. Save the record.
9. Repeat steps 5 – 8 to create the other four material records for the SA-97000 item routing using the field values in the table above for each material record.
10. For material records to which you need to add a note, follow these steps:
    a. Select **Actions > Notes for Current**.
    b. Type a [subject] for the note into the Subject field.
    c. Select the Internal check box.
    d. Type the [text of the note] (or copy and paste) into the Note field.
    e. Click OK.
11. To specify alternate materials for an operation, follow these steps:
    a. Make note of the Alt Group number for the item for which you are specifying alternate materials.
    b. Select **Actions > New** on the Current Materials form.
    c. Select the item to be an alternate material from the Material drop-down list.
    d. Select the same number you made note of above from the Alt Group drop-down list.
e. Enter other information to complete the material record.
f. Save the record.

12. Apply this set of steps to add the materials to operations for the item routings in the other parts of this exercise using the values in the appropriate tables for the material records.

Part 2: Materials for item GTZ-970

Use the information in the following table to add materials to the current operations of item GTZ-970:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Material</th>
<th>Qty</th>
<th>Per</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 - FINAL ASSEMBLY</td>
<td>SA-97000</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - FINAL ASSEMBLY</td>
<td>SA-61000</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - FINAL ASSEMBLY</td>
<td>LX-01</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>15 - OUTSIDE PROCESS</td>
<td>OUT-CG</td>
<td>1</td>
<td>Lot Qty</td>
</tr>
</tbody>
</table>

Part 3: Materials for item PHANT-22

Here's a graphical representation of the material structure of the first level of PHANT-22.

```
Material structure for item PHANT-22. = first level
```

Use the information in the following table to add materials to the current operations of item PHANT-22:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Material</th>
<th>Qty</th>
<th>Per</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 - PHANTOM</td>
<td>LX-01</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - PHANTOM</td>
<td>SA-97000</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - PHANTOM</td>
<td>SA-61000</td>
<td>2</td>
<td>Unit</td>
</tr>
</tbody>
</table>
Part 4: Materials for item MTN-21

Here's a graphical representation of the material structure of the first level of MTN-21.

```
Material structure for item MTN-21: first level

MTN-21

PHANT-22

21-SFD
```

Use the information in the following table to add materials to the current operations of item MTN-21:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Material</th>
<th>Qty</th>
<th>Per</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 - ASSEMBLY</td>
<td>LX-01</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>10 - ASSEMBLY</td>
<td>SA-97000</td>
<td>1</td>
<td>Unit</td>
</tr>
</tbody>
</table>

---

---
Check your understanding

Describe how the Effective Date field on the Current Materials form is used.

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

If a material for an operation has an Alt Group Rank value of 1, it indicates that

a) The material is the primary material in an Alt Group
b) The material is not part of an Alt Group
c) The material is the first alternate material in an Alt Group
d) The material is sequenced as the first component of an assembly
True or false. Materials for an operation may only be inventoried items.
Lesson 6: Adding outside operations

Estimated time
40 minutes

Learning objectives
After completing this lesson, you will be able to:

- List the system records that must be set up for using outside operations in a routing.
- Explain the process for creating an item for an outside operation.
- Describe the procedures for processing an outside operation.

Topics
- Introduction
- Setting up outside operations
- Processing an outside operation
Introduction

In the last lesson, by adding materials to item routings, you completed some bills of material. In the next lesson, you will learn how to view BOM records and perform other BOM activities, but first we need to look at the special considerations and settings that outside operations need to have.

If the actual work on an operation is performed at a location other than your shop floor, you must perform special steps to capture the status of the operation for accurate APS, scheduling, and costing. If you do not represent and manage an outside operation properly, the effects can ripple down through subsequent processes, resulting in an over-conservative plan and schedule.
Setting up outside operations

If you have outside operations in your routing, you can set them up so that the system:

1. Captures the cost of the outside processing in a separate general ledger (GL) account.
2. Uses a purchase order (PO) to order the work from the vendor.
3. Uses that PO’s due date when scheduling the finish date of the operation (see the APS or Scheduler help topics for more information).
4. Automatically prompts you to issue the processed material to the job when you receive the PO and then moves the finished pieces to the next routing step.

To take advantage of SyteLine’s special outside operation features, you need to use a specific combination of operation, material, work center, resource, and item settings which are detailed below.

On the Scheduling Shifts form
Create a scheduling shift consisting of one shift interval that starts on Sunday at 00:00 hours and ends Saturday at 24:00 hours (7 days x 24 hours).

You will be using an infinite resource group to represent this process.

Therefore, you need a 24x7 shift to ensure that the planning and scheduling programs process the infinite resource consistently (scheduling ignores the shift and considers the resource always infinite, while APS considers the resource infinite only while on-shift).

On the Resources form
Follow these steps:

1. Create a new resource for the outside operation.
2. On the General tab, you can accept the default values for the fields.
3. Select the Shifts tab. In the ShiftID#1 field, select your 24x7 scheduling shift that you created above.

On the Resource Groups form
Follow these steps:

1. Create a new resource group.
2. In the Infinite Capacity After field, type 0. This sets the resource to infinite capacity for planning purposes.
3. Select the Infinite check box to set the resource to infinite capacity for scheduling purposes.
4. Select the Resources tab. Add your outside resource as a member of the group.
**On the Work Centers form**

Follow these steps:

1. Create a work center to use for outside operations. You can use the same work center for more than one outside operation.
2. On the Scheduling tab, select the Outside check box. Defining the work center as Outside signals the planning and scheduling processes to perform special calculations so you don't have to enter the time the parts have been away from the shop. The Outside work center also captures the cost in the Outside GL account you set up on the Product Codes form.
3. Select the Resource Groups tab. Add the infinite resource group you created earlier in this procedure.

**On the appropriate Operations form**

Follow these steps:

1. In the WC field, select your outside work center.
2. In the Fixed Schedule Hours field (if you are using fixed schedule hours) or the appropriate hours per piece/pieces per hour field, type the number of hours that corresponds to the normal lead time for this outside operation.
   
   **Note**: Regardless of whether you specify Fixed Schedule Hours, the system temporarily switches the operation to fixed schedule hours during the planning or scheduling run.
3. Set the Move and Finish times to reflect transit time to and from the vendor.
4. Set the Fixed or Variable hours equal to the time it will take the vendor to complete this operation.
   
   **Note**: Remember: these should be stated using a 24x7 calendar.
5. Select the Resources tab and verify that your infinite resource group is displayed. If it is not, select it now.
6. Select the Costs tab and type 0 into all of the costing rate fields. The material you issue to the operation will capture the cost of the outside operation.
**On the Items form**

Follow these steps:

1. Create an item to represent the item your outside operation will be providing.
2. Clear the Stocked check box.
3. In the Source field, select Purchased. This allows you to cross reference the material on the bill of materials to a PO.
4. In the Type field, select Other. This Type code prevents the system from creating planned orders for this item (instead, you will use the cross-reference feature).
5. Consider how to track cost for this purchased item. To apply the cost of the outside operation only to this order, set the Cost Type to Actual, set the Cost Method to Specific, and select the Lot Tracked check box on the Controls tab.
   
   **Note:** If you do not make it lot tracked, you run the risk of revaluing all items in a specific location when you receive them.

**On the appropriate Materials form**

Follow these steps:

1. Find the job and your outside operation.
2. Add a material record for the outside operation item.
3. In the Quantity field, type 1.
4. Select the Lot Quantity radio button (so the quantity is 1 per lot).

**Note:** You may include multiple outside material records on an operation. When scheduling the finish date of the operation, APS and the Scheduler will use the order with the latest due date.
Processing an outside operation

After setting up the outside operation, follow these steps to process it:

1. On the Unposted Job Transactions form, enter a transaction to move the WIP from the previous operation to the outside operation.

2. Use the Post Job Transactions form to post the transaction.

3. On the Operations form, make sure all operations previous to the outside operation are marked as Complete.

4. Create a source purchase order. You can do this for individual orders by clicking Source on the Materials form. You can also do this for a range of orders by using the Material Planner's Workbench. If you click Source, be sure to open the PO and select a vendor. A third method can be used, using outside processing to automatically launch the PO. Please refer to Outside Process Management help topics.
   - If you have scheduled the job, the sourced PO line due date will be set equal to the scheduled end date of the operation. You can update the PO line due date.
   - If you have not scheduled the job, the sourced PO line due date will be set equal to the start date of the job. You can update the PO line due date.

5. Physically send the purchase order and materials to your vendor. Make sure you have the correct cost on the PO and that the Due Date is set to the scheduled end date of the operation.

6. Adjust the PO line item due date as necessary.

7. Receive the materials from the vendor. The receipt transaction should automatically open up a form to issue the materials to the job and then another form to record this operation complete and move the materials to the next operation.
Scenario: Adding outside operations

In this scenario, you will be setting up and using an outside operation. This scenario does not include detailed steps so that you have the opportunity to apply the knowledge and skills you have learned in this lesson. You are encouraged to experiment in this scenario as a means to better understand system behavior. For this scenario:

To be more cost effective, we will subcontract the painting of our model SA-55000 chromium-steel racing assemblies to Wilcox Processes. Progressive Cycles will still perform the priming and prep-work for the process (operation 10). However, the item routing and Bill of Materials need to be updated to accommodate the outside process.

Applying the procedures that were covered in this lesson, perform the activities described in the tables below.

### Operations

<table>
<thead>
<tr>
<th>Form</th>
<th>Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scheduling Shifts</td>
<td>Verify you have a 24x7 scheduling shift already set up.</td>
</tr>
<tr>
<td>Resources</td>
<td>Create an outside resource. Assign it the 24x7 shift.</td>
</tr>
<tr>
<td>Resource Groups</td>
<td>Create an outside resource group called PT-OUT. Associate the resource with the group. Make sure it's set to infinite plan and schedule.</td>
</tr>
<tr>
<td>Work Center</td>
<td>Create a work center called PT-OUT. Flag it as an outside operation. Associate the resource group with this work center. Set all costing information to 0.</td>
</tr>
<tr>
<td>Operations</td>
<td>Delete operations 20 and 30 from SA-55000. Replace them with operation 25. It will take 1 day to move the items to and from the vendor. It will take on average 3 days to process a batch. Set the hours appropriately. Make sure the costing information is set to 0.</td>
</tr>
</tbody>
</table>

### Materials

<table>
<thead>
<tr>
<th>Form</th>
<th>Setup</th>
</tr>
</thead>
</table>
| Items | Add the following new item: PT-OUT  
  - Description: Paint, Outside Process  
  - Cost Method: Specific Source: Purchased  
  - Product Code: OUT  
  - Type: Other  
  - U/M: EA |
| Materials | Add the material to the outside operation's routing. |
Check your understanding

How should a scheduling shift for an outside operation resource be set up?
_____________________________________
_____________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

What should be done on the Costs tab on the Current Operations form for an outside operation?
____________________________________________
___________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

SyteLine: Using Bills of Material/Engineering Change Notices
What item type should be used for an item that is created to be used in an outside operation?
Lesson 7: Other BOM activities

Estimated time
40 minutes

Learning objectives
After completing this lesson, you will be able to:

- Explain the use of the Item Current Routing and Indented Current BOM reports.
- Describe the procedure to copy a BOM/routing.

Topics
- Introduction
- Generating Item Current Routing Report
- Generating Indented Current BOM Report
- Copying routings/BOM
- Use the Engineering Workbench for BOM activities
Introduction

You have successfully completed the procedures for setting up the bills of material for the two new products.

There are other activities in SyteLine that you may find useful when working with BOMs.

These activities include:

- Generating some useful reports of BOM information
- Copying routings/BOMs
- Using the Engineering Workbench to create or edit BOMs
Generating Item Current Routing Report

The Item Current Routing Report shows each operation for the standard job for a selected range of items, product codes, and operations. The report also includes the materials (including any alternate materials, if you are using APS) and notes that are associated with each operation.

You can elect to include the following in the report:

- A, B, and C codes
- Operation, material, internal, and external notes
- Item materials
- Reference fields

Sample output

![Sample output image]

*Item Current Routing Report for item SA-97000 – sample output*
Generating Indented Current BOM Report

The Indented Current BOM Report shows the indented component material requirements of a parent item, indicated in the item’s current BOM as of a given effective date.

You can produce this report for a range of items and product codes, and for A, B, and C codes.

You can select the types of material to include: Material, Tool, Fixture, and Other. You can also select the source of the material: Purchased, Transferred, and Manufactured.

You can include stocked and/or non-stocked items in the report. You can also print by only zero balance items, and optionally include reference fields.

Sample output

![Indented Current BOM Report]

Indented Current BOM Report for item SA-97000 – sample output
Copying routings/BOMs

You can freely copy back and forth between the Current, Job, Estimate, and Production Schedule BOMs using the Copy Routing/BOM activity. You can also use the actual values from jobs versus those planned on a BOM. Once you copy a BOM, you can edit the new copy of the routing and bill of materials as necessary.

Copy Routing BOM form

It is possible to have several routings and BOMs for the same item. You could have a routing and BOM for a current standard, a production schedule, and a job that were each unique, but all for the same item. This allows for the flexibility to accommodate differences when manufacturing an item as a job or as a production schedule.

To copy a routing/BOM:

1. Open the Master Explorer > Modules > Production > Jobs > Activities > Copy Routing BOM form.
2. Select or enter appropriate data in the fields on the form to specify the elements of a routing or BOM that you want to copy. Use the table below as a guide for the usage of the various fields.

   Many of the fields on the form are grouped into sections: the From section on the left side of the form and the To section on the right side. This allows you to set a source and a destination or target for various elements in the copy activity.

3. Click Process to complete the copy activity.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>From Category</td>
<td>Select the code to specify the source of the copy for the routing and the bill of materials (BOM):</td>
</tr>
<tr>
<td></td>
<td>- <strong>Job</strong>: to copy the setup and run hours shown on the Standards tab on the Job Operations form and the material quantities and material costs shown on the Materials tab on the Job Materials form.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Current</strong>: to copy the item current routing and BOM from the Items form.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Actual Job</strong>: to copy the actual, posted setup and run hours and actual material quantities and costs from the job. These values were posted through job transactions after the job was run and are shown on the Accum Values tab of the Job Operations and Job Materials forms.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Estimate Job</strong>: to copy the routing and BOM from an estimate job.</td>
</tr>
<tr>
<td></td>
<td>- <strong>PS Item</strong>: to copy the routing and BOM from a production schedule item.</td>
</tr>
<tr>
<td></td>
<td>- <strong>PS Release</strong>: to copy the routing and BOM from a production schedule release.</td>
</tr>
</tbody>
</table>

The category selected in this field determines which other fields on the form are available or required.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| **To Category** | Select the code to specify the target of the copy for the routing and the bill of materials (BOM):  
  - **Job**: to copy the routing and BOM to a job.  
  - **Current**: to copy the routing and BOM to a target item’s current routing.  
  - **Estimate Job**: to copy the routing and BOM to an estimate job.  
  - **PS Item**: to copy the routing and BOM to a production schedule item.  
  - **PS Release**: to copy the routing and BOM to a production schedule release. The release you are copying to must exist, must have a status of Planned or Released, and must not have any posted production schedule transactions against it.  

When a job or production schedule has a status of Released, a message displays indicating that you are adding operations to a released job or production schedule.  

**Notes**:  
  - If you leave this field blank, the next available job number will be used (this number will display at the conclusion of the copy process).  
  - If the job number in the To section has a released status, the existing routing and bill of materials cannot be modified. However, additional routings and bills of material can be added to the end of the existing routing. |
| **Job** | In the From section, type or select the number of the job or estimate from which the information will be copied.  

In the To section, type or select the number of the job or estimate to which the information will be copied.  

**Notes**:  
  - If you leave this field blank, the next available job number will be used (this number will display at the conclusion of the copy process).  
  - If the job number in the To section has a released status, the existing routing and bill of materials cannot be modified. However, additional routings and bills of material can be added to the end of the existing routing. |
| **Sched ID** | In the From section, type or select a valid production schedule ID from which the information will be copied.  

In the To section, type or select a valid production schedule ID, a new production schedule ID, or leave it blank and let the system create a new production schedule ID. |
| **Rework** | If the displayed job is a rework order, the Rework check box will be selected by default.  

**Notes**:  
  - If the target job (or estimate job) displayed in the To section is a rework order, you can copy a material to the job BOM that is the same as the job’s end item. This recursive BOM structure is allowed only for rework jobs.  
  - You cannot copy a job structure to a new job if the job BOM contains a sub-job that is a rework order.  
  - You cannot copy materials from a rework order to a current BOM. |
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>Select the item from which to copy the current routing. It must be an inventoried item.</td>
</tr>
<tr>
<td>Release</td>
<td>Select the due date of the production schedule release from which to copy the routing/BOM information.</td>
</tr>
<tr>
<td>Revision</td>
<td>Type the revision number of the item.</td>
</tr>
<tr>
<td>Starting and Ending Operation</td>
<td>Type the range of operations to copy. The default will be the starting and ending operation numbers from the job, production schedule, or current routing. These fields can be overwritten as needed.</td>
</tr>
<tr>
<td>Copy UET Values</td>
<td>Select this field to copy any existing User Extended Table (UET) values from the source routing/BOM.</td>
</tr>
<tr>
<td>Copy Indented BOM</td>
<td>The default setting is No. Select Yes to copy the BOM and create sub-jobs for any current subassembly materials within the BOM that have a Reference of Job. <strong>Note</strong>: When you first create the sub-jobs in this manner, the Start and End dates on those jobs will be blank. The next time you run APS Planning, the system will populate these dates based on the current plan data. If you are using MRP, you must run Scheduling to populate the blank dates on the sub-jobs.</td>
</tr>
<tr>
<td>Extend by Scrap Factor</td>
<td>The default setting is No. Select Yes to use the scrap factor displayed on the Current Materials form as the variable for increasing the quantity on sub-jobs.</td>
</tr>
<tr>
<td>Option</td>
<td>Select a destination for routings and BOMs being copied or accept the default of Insert Range.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Delete All</strong>: Deletes the information specified. In the routing example, this option does not re-sequence the operation numbers.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Insert Range</strong>: Inserts the information and re-sequences the operation numbers. For example, if you copy a routing with Operations 10, 20, 21, and 22 to a blank routing, the Insert Range option re-sequences the numbers to 10, 20, 30, and 40.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Replace Range</strong>: Replaces existing information. In the routing example, this option does not re-sequence the operation numbers.</td>
</tr>
<tr>
<td></td>
<td>On some forms, this field is disabled if the copy “TO” field is left blank.</td>
</tr>
<tr>
<td>Labor, Material, or Both</td>
<td>The default setting is Both. This field is used to further define what portion of a routing to copy.</td>
</tr>
<tr>
<td>After Oper</td>
<td>Type the operation number after which to insert the new routing.</td>
</tr>
</tbody>
</table>
### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effective</td>
<td>Select a date to copy only non-expired BOMs or accept the default of the current system date.</td>
</tr>
</tbody>
</table>
| Copy to PS Release BOM | Select this check box to copy the production schedule item’s routing/BOM to any of the production schedule item’s releases that do not have a routing/BOM.  
If the PS item does not contain a routing/BOM, the item’s current routing/BOM will be copied to the releases.  
This field is active only if the To Category is set to PS Item. |

### Copying alternate materials
If you are using the APS planning mode, you can use the alternate material feature. When you copy a current routing/BOM from one item to create a current routing/BOM for another item, any alternate materials specified in the source routing/BOM are copied to the new routing/BOM as alternate materials.

When you copy a current routing/BOM to create another type of routing (such as a job or production schedule routing/BOM), the system copies any alternate materials APS selected in the last plan.

### Other copying methods
There are three other methods you can use to copy BOMs.

1. **Using the Roll Current to Standard utility.**  
   This is the only method you can use to create a standard BOM.

2. **Clicking Copy Routing/BOM on the Job Orders form copies the Current BOM to the Job BOM.**

3. **Changing the Status of a Job Order.**  
   You cannot release a job without a BOM; therefore, when you change the status of a job, the system will prompt you to copy the Current BOM.
Use the Engineering Workbench for BOM activities

The Engineering Workbench form allows you to create and maintain different types of routing/bills of material from one form. It allows you to create and maintain routing/bills of material by easily adding or removing materials from operations.

![Engineering Workbench form]

Selecting the transaction

1. In the View field, select the type of routing/BOM: current (inventory item), standard, job, estimate, or production schedule.
2. Click the filter button in the toolbar.
3. Use the header fields to select the item, job, or production schedule to which you want to add routing/BOM information.
4. Click the filter button again. Any existing routing information for the item, job, or schedule is displayed.
Creating the routing

1. In the Operations grid, add a new record for each new operation in the routing. Use the grid fields to select a work center and define operation setup, queue, and run times, as well as the start and end date and other information about the operation.

2. After adding all the operations for the routing, select Actions > Save.

3. If you need to define resources for an operation beyond the default resource group defined for that operation's work center:
   - Right-click the operation number in the Operations grid and select Details. The appropriate Operations form opens, with the record for this operation displayed.
   - In that form, select the Resources tab and define the crew or machine resource groups that this operation requires in order to be processed, as well as parameters related to the resource groups.
   - Save the record and close the form.

4. If you need to define costs for an operation:
   - Right-click the operation number in the Operations grid and select Details. The appropriate Operations form opens, with the record for this operation displayed.
   - In that form, select the Costs tab and define the values used in costing this operation.
   - Save the record and close the form.

Adding materials

An Engineering Workbench record containing a new operation must be saved before you can add materials for the operation.

1. In the Materials grid, add a new record. Select an operation for which you want to define a material. Then select or enter the rest of the information about the material. You can add multiple lines defining different materials for a single operation.

2. Once you have added all the materials for the operations you defined, select Actions > Save to save the new materials.
Viewing the new routing/materials in the left tree pane

The left pane of the Engineering Workbench form contains a tab for each of the following routings/bills of material:

- Current
- Standard
- Job
- Estimate
- PS Item
- PS Release

To see in the left pane the new operations or materials you added, either close and reopen the Engineering Workbench form, or click the filter button on the left pane and click OK in the dialog box that appears. Either method refreshes the tree pane.

The tree display is shown here:

```
<table>
<thead>
<tr>
<th>Current</th>
<th>Standard</th>
<th>Job</th>
<th>Estimate</th>
<th>PS Item</th>
<th>PS Release</th>
</tr>
</thead>
<tbody>
<tr>
<td>FA-10000,Bicycle,Model-30,26&quot;,REV-2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10,FA-400,Final Assembly Area</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1,SA-50910,Frame,Assembly,Standard Carbon-S</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2,SA-61500,Wheel,Assembly,26&quot;,</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3,PB-10000,Seat,Assembly,Standard,</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4,TA-30000,Handle-Bars,Upright,</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5,LB-34000,Tool,Assembler-Wheel,</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

*Left pane of the Engineering Workbench form*

You can collapse the tree into a simpler view by selecting the collapse symbol next to each item or operation. For example, suppose you want to look at operations for the item, without displaying the materials. Click the collapse symbol to the left of the operation, and the materials are hidden in the collapsed tree. The word “Alternate” appears next to any material that is specified as an alternate material on a current operation.

**Note:** You cannot add or remove operations or items from routing/BOMs in the left pane. Use the right pane of the Engineering Workbench form for maintaining routing/BOMs.

You can copy operations and materials from any BOM in the left pane to the BOM you are editing in the right pane. To do this, expand the tree display in the left pane as necessary, select an operation or a material and click the Copy Operation or Copy Material buttons to copy it to the BOM displayed in the right pane.
Check your understanding

Give an example of how you might use the Copy Routing/BOM activity.

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

List two advantages that using the Engineering Workbench to create a BOM provides.

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
Lesson 8: Setting up Engineering Change Notices (ECNs)

Estimated time
30 minutes

Learning objectives
After completing this lesson, you will be able to:

- List the steps for activating ECN control.
- Identify the supporting code lists that must be set up for ECNs.

Topics
- Introduction
- Activating ECN control
- Setting up change reason codes
- Setting up ECN priority codes
- Setting up ECN distribution codes
Introduction

SyteLine Engineering Change Notices (ECNs) are used to control and track revisions made to a bill of materials or to the routing of an item. The ECN process is crucial in ensuring high quality, safety, and consistency of products.

You will want to control changes to your BOM definitions. There are a few ways to do this in SyteLine:

- Use general security settings so that only your engineers can change the current BOM.
- Limit access to BOM forms.
- Use Engineering Change Notices (ECNs).

ECNs are useful because they:

- Allow you maintain a comprehensive audit trail of changes to the bills of material and routings.
- Maintain distribution codes for who must be notified of ECN changes.
- Require approvals before implementing changes on jobs or estimates.
- Prevent changes outside of the ECN process.

Before you implement ECN control you need to determine:

- Which BOM types and items within those BOM types you need to control.
- The various reasons that would require changes.
- The priorities for implementing ECNs.
- Distribution lists of the people who should be notified of changes and those who can approve changes.

In this lesson you will learn how to activate and set up ECN controls.
Activating ECN control

The Inventory Parameters form is where global ECN control is established for various types of bills of materials.

**Inventory Parameters form**

To globally activate ECN control of BOMs, follow these steps:

1. Open the Master Explorer > Modules > Codes > Parameters > Inventory Parameters form.
2. Select an option from the ECN Use for Current BOM/Routings drop-down list. Refer to the table below for descriptions of the options.
3. Select an option from the ECN Use for Job BOM/Routings drop-down list. Refer to the table below for descriptions of the options.
4. Select an option from the ECN Use for Estimating BOM/Routings drop-down list. Refer to the table below for descriptions of the options.

The options for the ECN Use for fields include:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>All changes to BOMs and routings of this type must be made using ECNs. The item's Revision Track field is ignored.</td>
</tr>
<tr>
<td>Individual</td>
<td>Only BOMs and routings for those items with the Revision Track option selected on the item record require the use of ECNs.</td>
</tr>
<tr>
<td>Never</td>
<td>ECNs are not used.</td>
</tr>
</tbody>
</table>

**Note:** There is no ECN control for Production Schedule BOMs. Production schedules, while they can be changed, post values on the Standard BOM.
Item records

To activate ECN control at the item level, follow these steps:

1. Open the Master Explorer > Modules > Materials > Inventory > Items form.
2. Filter for an item or select the item from the drop-down list.
3. Select or type ECN-related information in the appropriate fields of the item header, using the field descriptions in the table below as a guide.
4. Save the record.

Fields related to ECNs

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revision</td>
<td>Used to track multiple routings and bills of material for an item. The revision field displays the current revision of an item. If no revision is entered the user cannot copy to a new revision.</td>
</tr>
<tr>
<td>ECN</td>
<td>Indicates whether there are pending Engineering Change Notices for an item.</td>
</tr>
<tr>
<td>Revision Track</td>
<td>If any of the ECN Use for Current, Jobs, and Estimates fields on the Inventory Parameters form are set to Individual and the Revision Track check box has been selected, then all changes made to this item's BOM must be made through Engineering Change Notices.</td>
</tr>
<tr>
<td>Drawing Number</td>
<td>Displays the drawing number for the current revision.</td>
</tr>
</tbody>
</table>
Setting up change reason codes

Every ECN requires a reason for the changes being made. In SyteLine, you can set up a standard list of reasons and choose from these when you create an ECN.

ECN reason codes

The ECN Reason Codes form is found in the Master Explorer > Modules > Materials > Engineering Change Notices > Files folder. Reason codes can be added to the ECN Reason Codes form by clicking the next available line on the grid and typing a code number and description. ECN reason codes will print on various Engineering Change Notice reports.

**Note:** The codes in the image above are for reference information only.
Setting up ECN priority codes

Priorities should be established to define suggested time limits for making changes. In SyteLine you can set up a standard list of priorities and choose from these when you create an ECN.

**ECN priority codes**

The ECN Priority Codes form is found in the Master Explorer > Modules > Materials > Engineering Change Notices > Files folder. Priority codes can be added to the ECN Priority Codes form by clicking the next available line on the grid and typing a code number and description. ECN priority codes will print on various Engineering Change Notice reports.

**Note:** The codes in the image above are for reference information only.
Setting up ECN distribution codes

For every ECN, the approvers and those who need to be notified of changes can be established through the use of ECN distribution codes. Each distribution code defines a group of people for ECN notifications. In SyteLine you can set up standard distribution codes and choose from these when you create an ECN.

ECN distribution codes

The ECN Distribution Codes form is found in the Master Explorer > Modules > Materials > Engineering Change Notices > Files folder. Distribution codes can be added to the ECN Distribution Codes form by clicking the next available line on the grid and typing a code number and description. ECN distribution codes will print on various Engineering Change Notice reports.

Note: The codes in the image above are for reference information only.

To specify a list of names to associate with each code, add a note by selecting Notes for Current from the Actions menu. For more information on using notes, see the online help.

How to automatically forward ECNs for approval

The distribution list is for information purposes only. If you would like ECNs to be forwarded to various people for approval or work, you will have to use SyteLine Event Handler tools that manage work flows.
**Scenario: ECN setup**

In this scenario, you will be setting up some of the various code lists used for ECN control. Applying the procedures that were covered in this lesson, add the various ECN codes in the table below to the appropriate ECN code lists.

Verify the system is set up to control changes to current BOMs on an item-by-item basis. Next, create the following ECN codes.

<table>
<thead>
<tr>
<th>Code</th>
<th>Code #</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Priority</td>
<td>05</td>
<td>Within next MPS</td>
<td>NA</td>
</tr>
<tr>
<td></td>
<td>06</td>
<td>Within next planning horizon</td>
<td>NA</td>
</tr>
<tr>
<td>Reason</td>
<td>06</td>
<td>Incorrect dimensions</td>
<td>NA</td>
</tr>
<tr>
<td></td>
<td>07</td>
<td>New enhancement to product</td>
<td>NA</td>
</tr>
<tr>
<td></td>
<td>08</td>
<td>Change in customer specifications</td>
<td>NA</td>
</tr>
<tr>
<td>Distribution</td>
<td>06</td>
<td>Outside vendors</td>
<td>Cromax Metals</td>
</tr>
<tr>
<td></td>
<td>07</td>
<td>New enhancement to product</td>
<td>All team leaders</td>
</tr>
</tbody>
</table>
Check your understanding

What are the three BOM types that ECN control can be established for?

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

If the ECN Use for Current BOM/Routings parameter on the Inventory Parameters form is set to Individual, how would you activate ECN control for an item’s routing and BOM?

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
Lesson 9: Using Engineering Change Notices (ECNs)

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:
- Identify the steps for creating an ECN.
- List the steps for creating an ECN item.
- Describe the process for approval/disapproval of an ECN.
- Explain how item revisions are made.
- Identify the criteria for posting ECNs.

Topics
- Introduction
- Creating an ECN
- Creating ECN items
- Approving/Disapproving ECNs
- Maintaining item revisions
- Posting ECNs
Introduction

The diagram below shows the steps to making BOM changes using ECNs. Notice there are three ways to create ECN lines. In this lesson, you will learn how to perform each of the steps shown in the diagram below.

---

Engineering Change Notice control process

---
Creating an ECN

Before you can specify the changes to be made, you need to create an ECN record. You can associate multiple changes for multiple items to each ECN.

The Engineering Change Notices form is used for adding an Engineering Change Notice.

<table>
<thead>
<tr>
<th>Field</th>
<th>Option/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td></td>
</tr>
<tr>
<td>Requested</td>
<td>Default status upon creation of the Engineering Change Notice.</td>
</tr>
<tr>
<td>Approved</td>
<td>Indicates the Engineering Change Notice is approved to be posted. For an Engineering Change Notice to have a status of Approved, all Engineering Change Notice lines must either have a status of Approved or Not Approved. Once the status of the Engineering Change Notice has been changed to approved, no updates or additions to the Engineering Change Notice lines are permitted.</td>
</tr>
<tr>
<td>Complete</td>
<td>Engineering Change Notices can be changed to Complete through the following ways:</td>
</tr>
<tr>
<td></td>
<td>• Posting an Engineering Change Notice. This will post all lines that have an Approved status and will not post lines that have a Not Approved status.</td>
</tr>
<tr>
<td></td>
<td>• Manual Change. This will not post any Engineering Change Notice lines.</td>
</tr>
<tr>
<td></td>
<td>• Using the &quot;Change ECN Status Utility.&quot; This will not post any Engineering Change Notice lines.</td>
</tr>
<tr>
<td>History</td>
<td>This indicates that the Engineering Change Notice has been moved to the history file. Once moved to history, the Engineering Change Notice can be deleted.</td>
</tr>
<tr>
<td>Requested Date</td>
<td>References the date the Engineering Change Notice was entered.</td>
</tr>
<tr>
<td>Effective Date</td>
<td>References the target date of the Engineering Change Notice. Defaults to today's date.</td>
</tr>
<tr>
<td>Approved Date</td>
<td>References the date the Engineering Change Notice status was changed from Requested to Approved.</td>
</tr>
<tr>
<td>Completed Date</td>
<td>References the date the Engineering Change Notice status was changed to Complete.</td>
</tr>
</tbody>
</table>

The Engineer Change Notices form is found in the Master Explorer > Modules > Materials > Engineering Change Notices folder.

Three reports that you will find useful are the ECN Report, ECN Status Report, and the ECN by Item Revision Report.
Demo: ECN creation
Your instructor will demonstrate how to create ECN records.

Exercise 9.1: ECN creation
In this exercise, you will create ECN records.

Exercise steps
It has been determined that the item SA-61500 will now have all changes to the item posted using Engineering Change Notices. Enhancements are being made to our current wheel assembly, item SA-61500. We will need to create the ECN so that we can begin the process of making the necessary changes for this standard product enhancement.

- Make sure SA-61500 has revision tracking turned on.
- This ECN will be for the SA-61500’s Current BOM and is to be effective at the beginning of next month (the next production run).
- All managers are to be notified of the changes.
- Use yourself as the originator.

Further details regarding the specific changes being made will be given later.

1. Open the Master Explorer > Modules > Materials > Inventory > Items form.
2. Turn off the Filter-in-Place mode.
3. Select item SA-61500.
4. Select the Revision Track check box.
5. Open the Master Explorer > Modules > Materials > Engineering Change Notices > Engineer Change Notices form.
6. Turn off the Filter-in-Place mode.
7. Select Actions > New.
8. Type <Your Name> into the Originator field.
9. Select Within the Next Production Run from the Priority drop-down list.
10. Select New Enhancement to Product from the Reason drop-down list.
11. Select All Managers from the Distribution drop-down list.
12. Save the record.
Creating ECN items

**Adding an operation or material ECN manually**

The second step is to create ECN items. An ECN item is simply a change you want to make to a BOM. You can change operations and materials.

**Adding a single ECN item**

Use the Engineering Change Notice Items form to create and modify line items for an Engineering Change Notice (ECN). Creating and modifying line items enables you to influence an item's current routing, job routing, and estimate routing with respect to its operations, materials, and material references.

<table>
<thead>
<tr>
<th>Field</th>
<th>Option/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECN</td>
<td>The ID of the parent ECN</td>
</tr>
<tr>
<td>Status</td>
<td>Requested&lt;br&gt;This is the default when the line is added. Cannot post an item with this status.</td>
</tr>
<tr>
<td></td>
<td>Approved&lt;br&gt;The line status has been changed to Approved either manually or through the Change ECN Line Status utility. Can post an item with this status.</td>
</tr>
<tr>
<td></td>
<td>Not Approved&lt;br&gt;Indicates the line will not be posted, but will be referenced as having not been approved.</td>
</tr>
<tr>
<td></td>
<td>Hold&lt;br&gt;Indicates the line is not ready to be posted. Once on hold the line can be changed to Requested, Approved, or Not Approved.</td>
</tr>
<tr>
<td>Action Code</td>
<td>Refers to the type of modification that is to be performed to the Routing, BOM and/or Material References.</td>
</tr>
<tr>
<td></td>
<td>Add&lt;br&gt;The operation or material will be added to the item's BOM.</td>
</tr>
<tr>
<td></td>
<td>Update&lt;br&gt;The specified operation or material will be changed to what's shown on the ECN item.</td>
</tr>
<tr>
<td></td>
<td>Delete&lt;br&gt;The specified operation or material will be deleted from the item's BOM.</td>
</tr>
<tr>
<td>Item</td>
<td>The item that will have its BOM changed.</td>
</tr>
</tbody>
</table>
### Revision
The revision of the item that will be changed. This can be a past, current, or future revision. The field defaults to the revision number currently showing on the item record.

**Note:** If you approve an item for the current revision number, this field will become read-only. Therefore, if an ECN item will be part of what defines a new revision, type in the new revision number here even if you haven’t created it.

### Group
Enter a group number associated with this Engineering Change Notice item. You can use this field to make deletion of ECN items faster.

**Note:** If you want to delete a group of ECN items, open the Engineering Change Notice Items form and select Delete Group from the Action menu. You will be able to delete groups only when the item has a status that is other than Complete.

### Generating ECN items using mass material substitution
To create mass material substitutions, you'll use the Material Substitution ECN Item Generation form. This utility will create two ECN item records for each substitution:

- An ECN item with an action of add. This will add the material to the BOM with the effective date set on this form.
- An ECN item with an action of update. This will update the current material record with an obsolete date equal to the effective date on this form.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To ECN</strong></td>
<td>Any ECN items this utility creates will be added to this ECN.</td>
</tr>
<tr>
<td><strong>Line Status</strong></td>
<td>This is the status of the ECN item that will be created.</td>
</tr>
<tr>
<td><strong>Group Default</strong></td>
<td>The group value. This corresponds to the Group field in the ECN Items form.</td>
</tr>
<tr>
<td><strong>Effective Date</strong></td>
<td>When this substitution will be effective.</td>
</tr>
<tr>
<td><strong>Mfg Type</strong></td>
<td>Specify types of items to check for the material substitution.</td>
</tr>
<tr>
<td><strong>Current Material, Quantity, &amp; U/M</strong></td>
<td>Specify the material, quantity, and U/M you want to replace. If you want to substitute something else for this item regardless of the quantity on the material record, leave this quantity field blank.</td>
</tr>
<tr>
<td><strong>Substitute Material, Quantity, &amp; U/M</strong></td>
<td>Specify the new material, quantity, and U/M. If you want to retain the quantity setting for the current item, leave this quantity field blank.</td>
</tr>
</tbody>
</table>
Field | Description
--- | ---
**Starting & Ending Item, Product Code** | Specify a range of items and product codes to check for material substitution. Leave these fields blank to check all items and product codes for the selected Mfg. Types.

**Process Preview & Commit** | Select Preview and click Process to see all the ECN items that will be created. Select check boxes for items to process. Select Commit and click Process to actually create the ECN items.

**Copying ECN items**
Use the Copy Engineering Change Notices form to copy ECNs and History ECNs. When you copy ECNs, SyteLine also copies the fields on the Job Material Reference, Standard Material Reference, and Estimate Material Reference forms.

Field | Description
--- | ---
**From Type** | Select ECN for ECNs with a status of anything besides History. Select History for ECNs with a status of History.

**Line Status** | Filter for the types of lines you want to copy.

**From & To ECN** | Specify the source and destination ECNs for the copy process.

**Starting & Ending ECN Line** | Specify the range of ECN items you want to copy.

**Job Type** | ECN items are made for either Current, Job, or Estimating BOM types. Filter for the ECN items with the BOM types you select.

**Process Preview & Commit** | Select Preview and click Process to see all of the ECN items that would be copied. Select check boxes for items to copy. Select Commit and click Process to actually copy the ECN items.
Demo: ECN items creation
Your instructor will demonstrate how to create ECN items and ECN items for mass substitutions.

Exercise 9.2: ECN items creation
In this exercise, you will create ECN items and ECN items for mass substitutions.

Exercise steps
More instructions have been given regarding some of the changes being made to the SA-61500. Create ECN items for the changes below.

Two general notes. 1, all these changes are effective one week from today. 2, in order to track these changes we will need to note a new revision called "REV-1."

Material Update
To further reinforce the wheel assembly, the quantity of the spokes, the TA-70000, will be increased from 32 to 48 per unit. This material is found at Operation 10 of the SA-61500’s BOM. Leave the Effective Date blank.

Operation Update
After evaluating our process it has been decided to increase the run time at Operation 10 from 0.10 to 0.15 hours per unit. Leave the Effective Date blank.

Mass Substitution
Effective at the beginning of next quarter, the TA-30000, Upright Handle Bars, will be made obsolete. All current BOMs with TA-30000 will be replaced with the TA-31000. Use the mass substitution utility to perform this function.

You may want to print the Indented Where Used report to assist in this.

2. Turn off the Filter-in-Place mode.
3. Select the ECN you created in the previous exercise.
4. Click ECN Items.
5. Select Current Material from the Type drop-down list.
6. Select SA-61500 from the Item drop-down list.
7. Type REV-1 into the Revision field.

8. Click OK when the dialog box displays informing you that Item that has [Item: SA-61500] and [Revision: REV-1] does not exist.

9. Select operation 10 from the Operation drop-down list.

10. Select TA-70000 from the Seq drop-down list on the Material tab.

11. Type 48 into the Qty field.

12. Save the record.


14. Select Current Operation from the Type drop-down list.

15. Select SA-61500 from the Item drop-down list.

16. Type REV-1 into the Revision field.

17. Click OK when the dialog box displays informing you that Item that has [Item: SA-61500] and [Revision: REV-1] does not exist.

18. Select operation 10 from the Operation drop-down list.

19. Type 0.15 into the Labor Hour per Piece hours field.

20. Save the record.


22. Select the <same ECN that you have been using in this exercise> from the To ECN drop-down list.

23. Select the date for the start of the next quarter in the Effective Date field.

24. Clear the Estimate check box.

25. Clear the Job check box.

26. Select TA-30000 from the Current Material drop-down list.

27. Select TA-31000 from the Substitute Material drop-down list.

28. Select the Preview check box and click Process.

The grid on the form will list the items that will be affected by the change.

29. Select the Select check boxes for all items in the grid.

30. Select the Commit check box and click Process.

You can verify that the items were added to the ECN by opening the ECN record and clicking ECN items. Two line items should have been added for each item affected by the substitution: one for the old item with an obsolete date and one for the substitute item with an effective date.
Approving/Disapproving ECNs

The third and fourth steps are to approve or not approve ECN items and ECNs. There are three things to keep in mind:

- You must approve or not approve an ECN before you can post it.
- You must approve or not approve all ECN items before you can approve or not approve an ECN.
- You can change the status on the ECN and ECN items by manually updating the status fields or by using a change status utility.

Change ECN item status

From and To Item Status
Select the status of the items you want to change and what you want to change them to.

Starting and Ending ECN, ECN line
Select a range of ECNs and ECN lines, or leave these fields blank to change status on all ECN items.

Process Preview and Commit
Select Preview and click Process to see all the ECN items that would be changed. Select Commit and click the Process button to actually change the status.

Change ECN Status utility

From and To Status
Select the status of the ECNs you want to change and what you want to change them to.

Starting and Ending ECN
Select a range of ECNs, or leave these fields blank to change status on all ECNs.

Process Preview and Commit
Select Preview and click the Process button to see all the ECNs that would be changed. Select Commit and click the Process button to actually change the status.
Maintaining item revisions

The fourth (optional) step is to change an item revision. You can keep old item revisions and use them when you use the Copy Routing/BOM utility. Once the revision level has been changed, the old revision is copied to history where it can be retrieved or deleted and the new revision displays on the Items form.

Use the Change Item Revision form to save the current bill of materials for an item to history.

Change Item Revision utility

This utility allows the user to create an item’s revision level and store the old revision in history. Changes in the revision level may or may not necessitate a drawing number change. This activity can be run before or during the creation of the ECN, but it must be done prior to posting.

Prior to changing the revision level, it is suggested to display all pending ECNs for the specified revision. Use the filter on the Engineering Change Notice Items form to identify these ECN items.

Item

Specify the item you want to work with.

Copy From Revision and Drawing

Select the revision ID you are copying from.

- It is important to put in a beginning revision number in the revision field on the Items form prior to selecting ECN function required. You will not be able to copy from a blank record revision to a new revision. After the copy function is complete, the Items form will show the newest revision number.

New Revision and Drawing

Type the new revision ID. Type a new drawing number if you are going to change it.

Process button and outstanding ECN items grid

1. After filling out the information in this form, select Preview and click Process.
   a. The system will display a message indicating the number of outstanding ECN items that exist for the item. If there are ECN items, they will appear in the grid.
   b. The grid will display the revision each outstanding ECN item is for. If any revision in the grid does not match the revision you are changing the item to, you may want to either update the ECN or wait to make your revision change.
   c. If you want the ECN items to post to the new revision, cancel out of this utility without committing the change. Update the Revision field on each of the ECN items to revision you are updating the item to then return and change the revision.
   d. If you post ECNs to old revisions, they will NOT show up in the current BOM.

2. When there are no ECN items listed that conflict with your change, select Commit and click Process.
**Item Revision Report**

The Item Revision Report lists revisions that are associated with items, and the current item routing for any or all revisions of a particular item.

⚠️ If you need to use an old BOM that is saved to History, you can specify its revision number on the Copy Routing/BOM activity.

**Delete Item Revision utility**

This utility allows the user to delete old revisions from the system. The current revision level cannot be deleted.
Posting ECNs

Step six is to post the ECN. When the ECN status is “Approved” or “Not Approved” you may post the ECN. The system makes all the changes to the BOMs during posting. Once the ECN has been posted the status will automatically change to “Complete.”

Post Engineering Change Notice utility

This utility posts each Engineering Change Notice Item with a status of A-Approved for the selected Engineering Change Notice. Operations, Materials, and Material References may be Added, Updated, or Deleted for Current Operations/Materials, Jobs, and Estimates.

Note: This utility does not utilize the concepts of effective and/or obsolete Operations/Materials. Engineering Change Notice Items with an Action Code of D-Delete will delete the Operation/Material (rather than making it obsolete). Likewise, an Action Code of U-Update will modify the Operation/Material (rather than creating a new one effective in the future).
Demo: Item revision, ECN item and ECN approval, and ECN posting

Your instructor will demonstrate how to create an item revision, approve ECN line items and an ECN, and post an ECN.

Exercise 9.3: Item revision, ECN item and ECN approval, and ECN posting

In this exercise, you will create an item revision, approve all of the ECN line items in an ECN and then approve the ECN itself. Finally, you will post the ECN.

Exercise steps

Create a new revision for the SA-61500 Wheel Assembly. Our new revision is "REV 1." We will also be referencing a new drawing number, #SA-61500-01.

After you process the revision, open the Items form and verify you have a new revision and drawing number.

1. Open the Master Explorer > Modules > Materials > Engineering Change Notices > Activities > Change Item Revision form.
2. Select SA-61500 from the Item drop-down list.
3. Type REV-1 into the New Revision field. Type #SA-61500-01 into the Drawing field to the right of the New Revision field.
4. Select the Commit radio button and click Process.
5. Open the Master Explorer > Modules > Materials > Engineering Change Notices > Utilities > Change ECN Item Status form.
6. Select Requested from the From Item Status drop-down list.
7. Select Approved from the To Item Status drop-down list.
8. Select the <ECN you used in the previous exercise> from the Starting ECN drop-down list.
9. Select the first entry from the From ECN Line drop-down list.
10. Select the last entry from the To ECN Line drop-down list.
11. Select the Preview radio button and click Process.
12. Review the ECN line items in the grid to make sure that the correct ECN line items are being approved.
13. Select the Commit radio button and click Process.

15. Select **Requested** from the **From Status** drop-down list.

16. Select **Approved** from the **To Status** drop-down list.

17. Select the <ECN you used in the previous exercise> from the **Starting ECN** drop-down list.

18. Select the **Preview** radio button and click **Process**.

19. Review the ECN entry in the grid to make sure that it is the correct ECN to approve.

20. Select the **Commit** radio button and click **Process**.


22. Select the <ECN you used in the previous exercise> from the **ECN** drop-down list.

23. Select **Process**.
Check your understanding

Which utility do you use to save the current bill of materials for an item to History?

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

Select the statements below regarding the posting of ECNs that are true statements. Select all that apply.

a) Before an ECN can be posted it must have the status of Requested or Complete.
b) Before an ECN can be posted it must have the status of Approved or Not Approved.
c) During posting, the approved changes in an ECN are made to the affected routings/BOMs.
d) During posting, operations or materials set to be deleted in the ECN will not be processed.
e) Once posting is complete, the ECN status is changed to Complete.
Explain how ECN items and ECNs are approved or disapproved.

_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________
_______________________________________________________________________

What are the three methods for creating ECN items? Select all that apply.

- a) Manually create operation or material ECN items.
- b) Generate ECN items using mass material substitution.
- c) Select the Revision Track check box on the item record to create the ECN item.
- d) Copy ECN items from existing ECNs.
Course summary

Estimated time
30 minutes

Course objectives
Now that you have completed this course, you should be able to:

- Describe the general procedure for creating a bill of materials (BOM).
- Create item records for use in a BOM.
- Create item operation records, to include outside operations.
- Create resource and work center records.
- Create material records, to include alternate materials and add them to item operations.
- Generate BOM reports
- Copy routings and BOMs.
- Activate Engineering Change Notice (ECN) control and manage item revisions through ECNs.

Topics
- Course review
Course review

Select the BOM types that are supported by SyteLine. Select all that apply.

a) Current
b) Estimating
c) Industry
d) Job
e) Production Schedule
f) Standard
g) Temporary

Which one of the bill of materials types serves as a master template for the others?

a) Current
b) Estimating
c) Job
d) Production Schedule
e) Standard

Place the activities in the correct order that they must be performed to build a bill of materials. Place a number to the left of each step to indicate the sequence each step should be performed in.

1. Create item records.
2. Create work center records.
3. Create resource group records.
4. Create operation records for your end item.
5. Create shift records.
6. Create resource records.
7. Create material records for your operations.
Which of the following may be a phantom item in a BOM?

a) An item that cannot be seen  
b) A prototype of the end item being manufactured  
c) A non-inventoried item that is included for cost balancing  
d) A subassembly that is not stocked that may be sold as a replacement part

What is the maximum number of scheduling shifts for which a resource can be made available?

a) One  
b) Two  
c) Three  
d) Four

An item’s yield amount for an operation is linked to which field on the item record?

a) Shrink Factor  
b) Lot Number  
c) Safety Stock Percent  
d) Unit Cost

On the Operations form – Setup field, which of the following entries correctly displays a setup time of 20 minutes?

a) 20.00  
b) 0.20  
c) 0.33  
d) 20/60
If you enter a setup time on an operation record, what else must be selected so that the operation will incur the setup time?

a) A Setup Resource Group on the Resources tab
b) A Scheduler Rule on the Resources tab
c) A Break Rule on the Resources tab
d) An Effective Date on the Standards tab

What scheduling shift should be specified for a resource of an outside operation?

a) From Monday at 00:00 to Sunday at 24:00
b) From Monday at 00:00 to Friday at 24:00
c) From 08:00 to 16:00, Monday through Friday
d) From 08:00 to 16:00, Monday through Sunday

Which item source should be used for an item that is created to be used as an outside operation?

a) Manufactured
b) Other
c) Purchased
d) Transferred

Which three BOM types can ECN control be established for? Select all that apply.

a) Current BOM
b) Job BOM
c) Estimating BOM
d) Standard BOM
Place the steps in the correct order for making BOM changes using ECNs.

Place a number to the left of each step to indicate the sequence in which each step should be performed.

___ Approve or not approve ECN items
___ Post ECN
___ Create ECN
___ Approve ECN
___ Create ECN items
Appendix A: Review exercises

Topics
- Exercise 1
- Exercise 2
Exercise 1

The FA-30000, Euro cycle, will have some changes to the engineering drawing and to the process that will require a revision change. Print the Item Current Routing Report for this item. This will aid us in making the required changes. Go to the Change Item Revision screen and create a new revision level, REV-1, with Drawing Number FA-30000-D-01.

Next we will add an Engineering Change Notice for the changes that should occur in the next month, according to a manufacturing engineering request. All manufacturing employees should be notified of the change. The changes will only affect the Current BOM.

The first change requires that the WA-37000 be removed from the Current BOM via an Engineering Change Notice. The material will be replaced with the SA-61500. Enter the correct quantity of wheel assemblies per bicycle. Enter the following text to the material for the new wheel assembly:

Transport wheel assemblies ONLY on type K4 carts to prevent damage to spokes.

The second change is because Progressive Cycles has made a decision to perform their packaging in-house. Create one line to remove the packaging operation and another to add an internal operation. Material will also be added to the operation.

After entering the Engineering Change Notice lines, run both the Change ECN Line Status and the Change ECN Status utility to approve the Engineering Change Notice.

The Change ECN Line Status utility must be run prior to the Change ECN Utility. Once approved, post the Engineering Change Notice. Print the ECN Report for distribution and Item Current Routing Report to verify the changes. The Current Routing Report should be run for both the current and the previous revision.

Current operation information

<table>
<thead>
<tr>
<th>Oper</th>
<th>WC</th>
<th>Setup</th>
<th>LbrHrs/Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>PKG-10</td>
<td>0.25</td>
<td>0.12</td>
</tr>
</tbody>
</table>

Current operation text: Insert assembled bike into shipping box. Fasten box securely and apply identification label.

Current material information

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Quantity</th>
<th>Per</th>
</tr>
</thead>
<tbody>
<tr>
<td>PK-20000</td>
<td>Model 50 Box</td>
<td>1</td>
<td>Unit</td>
</tr>
</tbody>
</table>

Current material text: Shipping box should be partially filled with #STYRO-1 foam pellets to minimize impact during shipping.

_____________________________________________________________________
_____________________________________________________________________
_____________________________________________________________________
_____________________________________________________________________
_____________________________________________________________________
_____________________________________________________________________
_____________________________________________________________________
_____________________________________________________________________

112 Appendix A: Review exercises
© 2014 Infor Education
Exercise 2

Several changes will be going into effect for the FA-10000's BOM. Print the Item Current Routing Report to assist in this process.

The changes will necessitate a revision and drawing change. We will need to create our new revision, REV-3, for the FA-10000. The new drawing number to reference is FA-10000-D03.

Create an Engineering Change Notice to be effective the next production run for the FA-10000. This is a standard product enhancement affecting the FA-10000's Current BOM (no existing estimates or jobs are to be changed). All managers are to be notified of the change.

In the FA-10000, Model 30 bicycle, we will be replacing the SA-50910 with the SA-55000 frame assembly. These changes are against our new revision, REV-3.

Due to an increase in defects from shipping, FA-10000's packaging process will no longer be performed outside. Effective immediately, obsolete the outside operation from the Current BOM and add an internal packaging operation with the following production times:

<table>
<thead>
<tr>
<th>Move Hrs</th>
<th>Setup Hrs</th>
<th>Run Hrs/Pc</th>
</tr>
</thead>
<tbody>
<tr>
<td>.20</td>
<td>.25</td>
<td>.12</td>
</tr>
</tbody>
</table>

Add the following text to our new internal packaging operation: Insert assembled bike into shipping box. Fasten box securely and apply identification label. Get supervisor's initials on box indicating approval.

The following material will need to be added to our new internal packaging operation.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Quantity</th>
<th>Per</th>
</tr>
</thead>
<tbody>
<tr>
<td>PK-10000</td>
<td>Model 30 Box</td>
<td>1</td>
<td>Unit</td>
</tr>
</tbody>
</table>

Add the following text to the material: Inspect box for tears and punctures.

Print the ECN Report to review all Engineering Change Notice Lines. Use the Change ECN Line Status and the Change ECN Status utilities to approve the Engineering Change Notice. Post the Engineering Change Notice.

Print the Item Current Routing report to review FA-10000's new revision number, REV-3.
Appendix B: Reports and utilities

Topics
- Reports
  - BOM
  - ECN
- Utilities
  - BOM
  - ECN
Reports

BOM

Co-product Mix Report
Use the Co-product Mix Report to produce a list of co-products in a co-product mix. The report is sorted by co-product mix, and you can include all co-products in the co-product mix or only the lead co-product.

Co-product Mix Status Report
Use the Co-product Mix Status Report to display a list of co-products, sorted by co-product mixes, detailed cost distribution percentages, and co-product ratios.

Co-product Where Used Report
Use the Co-product Where Used Report to display a list of co-products and the co-product mixes that contain them. The report also indicates if the item is the lead co-product in the co-product mix.

Indented Costed BOM Report
The Indented Costed BOM Report shows the material requirements of a parent item and its components, with the components indented according to the item's bill of materials structure. These requirements are derived from the item's current BOM as of a given effective date.

The report lists the level of the component item, the unit of measure, the source code, and the quantity required. It also indicates whether or not the quantity is required per parent unit or lot, shows the lot size from the Items form, and shows the rolled up costs for each item in the selection.

The item's lot size is significant, because the per lot component costs are divided by the parent's lot size during roll up to calculate the unit contribution to the parent's cost.

Indented Current BOM Report
The Indented Current BOM Report shows the indented component material requirements of a parent item, indicated in the item's current BOM as of a given effective date.

You can produce this report for a range of items and product codes, and for A, B, and C codes.

You can select the types of material to include: Material, Tool, Fixture, and Other. You can also select the source of the material: Purchased, Transferred, and Manufactured.

You can include stocked and/or non-stocked items in the report. You can also print only zero balance items, and optionally include reference fields.

Item BOM Where Used Report
Use the Item BOM Where Used Report to print an indented list of items that can be produced from the selected items. By default, this report prints only one indented level. Select the Indented Level View field to print all indented levels.

Item Current Routing Report
Displays each operation for an item and the materials and text associated with each operation.

Item Feature Group Report
The Item Feature Group report lists each planning item and the feature groups for each planning item. This report is most useful during setup of feature groups to determine whether qualifier masks overlap. This report is sorted by item and by qualifier mask.

Planning BOM Report
Shows the planning BOM. Used with configuration.
**Single Level Current BOM Report**
Displays the first level of component materials on an item's BOM.

**Summarized Current BOM Report**
Displays the cumulative component requirements through the full BOM.

**ECN**

**ECN Report**
Displays a listing of Engineering Change Notices. Text and distribution lists are also available in the report.

**ECN by Item Report**
Displays a listing of Engineering Change Notices posted to Current, Estimate, and Actual Jobs.

**ECN Status Report**
Displays a listing of Engineering Change Notices by status.

**Item Revision Reports**
Displays a listing of routings and bills of material by revision level.

**Jobs Affected by ECNs Report**
Displays a listing of Current, Estimate, and Actual Jobs that have had Engineering Change Notices posted against them.
Utilities

BOM

*Current Bill of Materials Processor*

This process updates the Low Level Code for all items in Item Maintenance based on the product structure defined by the Current BOM.

*Current BOM Cost Roll Up*

This utility updates the material cost for all Current routings and Bills of Material and the roll up cost in Item Maintenance.

*Delete BOM Components*

The utility permits the user to delete a specified material from bills of material.

*Feature Group Verification*

Use the Feature Group Verification utility to check each planning item and its Featurized Bill of Materials (FBOM). The utility:

- Ensures that all groups in an item's FBOM are contained in the Feature Groups file.
- Verifies that there are no conflicting feature group qualifier masks.
- Verifies that there is at least one Include record for each feature group in the item's FBOM.
- Verifies that there is an Include Qualifier String with commas in the feature group's positions, if the feature group is non-mandatory, for a non-selection option.

*Roll Current Cost to Standard Cost*

The Roll Current Cost to Standard Cost form creates (or updates) a Standard Routing/BOM, which provides a benchmark by which to judge your Job Routings/BOMs. It also rolls the Current BOM to the Standard BOM. It copies the Current Unit Cost to the Std Unit Cost (Item Costs form), using the Purchased or Manufactured cost values, depending on what the source code for that item is. It also posts material transactions and journal entries to reflect the change in inventory value at each stock location. (The journal transactions have a reference of INV STDC.)

This utility does NOT roll up costs for alternate materials specified on the current routing/BOM.

*Substitute Bill of Material Components*

This utility permits the user to replace one item with another in all bills of material.

ECN

*Change ECN Item Status*

Allows the user to change the status of all selected Engineering Change Notice line items.

*Change ECN Status Utility*

Allows the user to mass change the statuses of Engineering Change Notices.

*Material Substitution ECN Item Generation*

Use the Material Substitution ECN Item Generation utility to create multiple line items for an ECN.

**NOTES:**

- The status of the ECN must be "Requested."
- You cannot add line items for Engineering Change Notices if the status is set to "Completed," "Approved," or "History."
• You cannot use this function to post changes.
• Clicking Process only allows you to generate ECN items. After you have generated the line item, you must post the ECN to create an actual change in the BOM.
• Substitutions to Current BOMs do not occur if the item numbers are different, the material being substituted for is an alternate material, and the material being substituted is already in the alternate group, or if the material being substituted is a non-inventory item.
Appendix C: Phantom items

Topics

- Phantom items
Phantom items

A phantom item is typically not stocked. In most cases, the MRP-APS will pass requirements through to the phantom item’s material components. To learn more about the exceptions, see the Planning training guide or the online help. Phantom items may be nested together and SyteLine supports bills of manufacturing up to 20 levels deep.

In the following example, our Current BOM for the FA-10000 contains a phantom assembly, the PB-10000. When MRP is processed, any requirements from the FA-10000 will be passed down its BOM to the PB-10000. MRP, seeing that the PB-10000 is a phantom item, will pass the requirements for the PB-10000 to its components: the CP-10000, CP-20000, CP-30000, and CP-40000. No planned orders are created for the PB-10000. Instead they are created for the CPs.

Current BOM structure for the FA-10000:
SyteLine's Copy Routing/BOM function also ignores the phantom, copying the phantom item's components in the place of the phantom item. If the FA-10000's Current BOM is copied to a Manufacturing Order, the CP-10000, CP-20000, CP-30000, and the CP-40000 would all appear at a higher level with no reference to the PB-10000. The resulting BOM will appear as follows.

Job/Production Schedule BOM structure for FA-10000: